Solo Defeat

Does Solo Defeat only work on FX Channels? When I do this on Audio Channels and/or VST Instrument Channels it doesn’t seem to work. The “solo” button turns orange and has the “D” on it, but they still stay muted.

You say, “they stay muted”. Were they muted previously (i.e. before hitting “Solo”)? If so, Solo defeat won’t unmute an already-muted event.

Forgive me if I used the wrong wording–I am coming from Logic and Pro Tools and learning lingo for a different piece of software is like trying to learn a new language.

I meant to say I’m trying to solo a MIDI track that is connected to an external instrument and that external instrument won’t solo along with the MIDI track the way an internal VST Instrument does. When I try to turn on Solo Defeat for that external instrument it still does not sound. Am I thinking Solo Defeat does something it’s not intended to do? I thought it was the same as in Pro Tools when you Option-click (or Command-click–I don’t remember off-hand) the solo button on a track to keep that track from muting when soloing is engaged. So when I said “it stays muted,” I was meaning it still sounds muted as opposed to the mute button staying on.

Ah, thanks for clarifying :slight_smile:.
In fact, I am now noticing some strange things here with Solo Defeat, myself (independently of the specific External Instruments case that you are talking about). But I want to check it out a bit further before adding any more comment, just in case it is a problem with my installation (although I don’t think that is the case), or maybe because of some setting in Preferences.

Please, if anyone else would care to verify whether Solo Defeat is working correctly (especially when soloing a MIDI track while an audio track is in Solo Defeat… it is not working for me here, the audio is muted, even though I still see activity on the audio track’s meter!).
Please, someone, confirm (or otherwise :wink: ), and please state which platform. Thanks :slight_smile:.

… just thinking out loud…
Well, it works if I also Solo Defeat the main Audio Output channels, but should that be necessary? (I mean, shouldn’t “Solo Defeat” also solo-defeat the logical audio routing from the source channel, same as it does when regular soloing?)

Bump.

I have a small project with 2x Audio Channels (in a Group Edited folder) and a click-track MIDI Channel of BD & HH -> GAO. Solo Defeat doesn’t seem to be behaving entirely logically.

  1. Solo the MIDI click-track. As we all know, both the MIDI and GAO Output Channels get soloed.
  2. Solo Defeat (Alt-click) one of the Audio Channels. Now you hear that too.

This works as expected. Now clear the Solos and Defeats.

  1. Solo one of the Audio Channels.
  2. Solo Defeat the MIDI click-track. No sound from the click-track!
  3. Solo Defeat the GAO Output. Now you can hear the click-track.

It seems to me that Solo Defeating the MIDI Channel should do the same down the signal path, in the way that Solo does. If I’m unaware of some issue that makes this undesirable, please let me know.

And perhaps “Deactivate All Solo” ought to do the same for all Solo Defeats too. It would be handy to have a way of doing this for the same reason the Deactivate buttons are there in the first place.

I have the same problem, seems to only work on audio tracks and not Instrument / VSTi tracks…
So i just bounced the audio (just a Groove Agent cowbell as a sidechain trigger) and use the new audio bounce.