Solo in place link with external FX?

So, I can’t find anything in the manual to suggest this behaves a different way…so, please let me know if there’s a setting I’ve missed somewhere.

Hardware setup: KSP8 connected via ADAT to the Echo Gina3g. I have IO 5+6 and 7+8 defined as stereo sends/returns for effects.

General mixing setup for me is to bus “like” instruments. So, I end up witha stereo drum buss…guitar buss…keys…etc…right? This is important to the issue.

Issue: The solo in place exemption doesn’t appear to be transitive through group solo’ing when using external FX. As example, let’s say I have kick, snare, toms…all routed with individual send levels to External FX1. The audio channels are also routed to the DrumSub group, which in turn is routed to the master stereo. So, if I hit “solo” on the kick, I get the kick, ExternalFX1, and DrumSub show as solo’d. I hear the kick track and it’s send FX. This is correct behavior. this works the same way whether you’re using internal plug in reverb or the external KSP8. Here’s where the issue is–let’s say I want to hear the drum kit–I solo the Drum Sub group channel. Guess what? Doesn’t solo the external FX. If I use a plug in reverb, it properly does.

I’ve got it worked around by sending the drum sub group bus to the external FX with no level…but, I shouldn’t need to do that–when I get into the guitar bus, it’s not going to be as simple. There may be 7 guitar channels with sends to 4 different time/pitch fxs (let’s assume all external, since internal works properly). I can’t NEED to also remember to assign an empty send to the buss itself.

Solo’ing a bus should solo everything send TO the bus…and every aux those tracks are sent TO individually. To reiterate, if I use a plugin reverb,this works exactly as it should. So, assuming I’m not missing some preference somewhere…is there an official bug report? Once I’m done with this project, I’ll update to the latest point release…but, I’m really hoping this is just ME missing a preference/setup option somewhere.

is the external Fx channel direct part of the drum subgroup?

I have no idea what you mean by “direct part”. The signal does not flow from the external FX into the Drum bus…

BTW…clarification on the work around. The workaround is not as I described with the empty send–it’s to insert a plug in reverb on the KSP8 channel, but leave it in bypass. Then Cubase properly solos…in the example, whether I solo the kick or the drum sub group…

It´s not part of the group, therefore not soloed. This is the same with plugin insert here (in C5.1 though).

Maybe I need to break this out. You can do this with a single track…although in the real world, it’s pointless with one track.

Assumesthe external aux busses are already configured–call Aux1Rtn here.

Create “group channel” called “drumgroup” with it’s output main stereo.
Create Kick ch with it’s output set to DrumGroup.
Import some kind of audio.
Send via aux on the KickChto external reverb.

Solo Kick Ch. What solos? KickCh, DrumGroup, and Aux1Rtn --you here the kick, in place and the FX being applied viathe aux. This is correct behavior for solo in place.

Remove all solos.

Now solo the DrumCh group. You should get the exact same thins solo’d…with a plugin reverb on Aux1, it DOES act the same for me. But, with a hardware reverb on Aux1, I get only the KickCh and DrumGroup solo’d–muting the Aux1 return and obviously the reverb being applied.

Are you saying it does NOT act this way? Or it always mutes Aux1 (incorrectly,IME) whether you usea plug in or an external reverb?

No, you shouldn´t. The reverb return is not part of the drumgroup until there´s a send activated from the group channel, or the return is routed to the group… Otherwise you can have to use solo defeat for the FX channel.

On 5.1 the behaviour is consistent independent of hardware- and software-insert in the FX channel - The return gets muted (correctly, IMO).

Well, then they half way fixed it in v6…although, I don’t remember it not behaving this way in v4 (where I came from).

No idea why you would not want the solo transitive. The kick has reverb–why would you not want to hear it when you solo the group? I understand what you’re saying-the fx return is not assigned to the group, but why does it solo itself when you solo JUST the kick (to continue with the example)? All soloing a group channel is doing is to solo the bus and all the channels that feed it–IMO, it should behave just like I clicked “solo” on the kick, then snare, then overheads, etc.

It’s more disappointing that it works the way I want it to when using a plug in reverb…yet the plug in reverbs don’t sound as good…

I’m about to buy a BUNCH of IO for the computer to integrate it into my studio as is…the different implementation of external vs internal is not going to sit well with me. I used this KSP8 with the same Soundcard with C4…seems like I’d have noticed this–the compensated hardware inserts seem to work like a champ.

Where is the solo defeat on a channel? Depending on how it handles sends of muted channels…I could live with setting ALL aux returns to ignore–that’s what I do on my digital mixer now.

Alt+click the solo button…got it. Will try next time I’m mixing.

…still shouldn’t act differently for plugs or external fx, right? You say 5 doesn’t. 6 does. I could swear the 4 I used for years behaved the way I think it should–and the way 6 does ONLY for plug ins.

If I solo a group I want to hear the channels that are assigned to the group. If I wanted to hear the reverb also, I´d assign it to the group (or I´d use a send from the group to the Fx). Given that this is the best way to keep the relation of dry signal / reverb when mixing with groups. That´s not different from “real world” behaviour. If you AFL groups on a console, you usually only hear the channels assigned to the group (Now well, AFL / PFL is not SIP, I know)
Let´s take a different example:
complete drumset: All channels´ outpus routed to a group. Additionally all channels get a send to a second group to apply parallel compression.Having it your way means whenever you solo the non-compressed drum group, it also activates the compressed group. Not what I personally want.

No, it shouldn´t and in C5 it doesn´t

Are we the only two with external FX?


The more I read about external effects hassles, the more I’m thinking about getting a Toft Mixer and forgetting about trying to integrate everything through software sequencers and hardware routing like TotalMix.

Go with the Focusrite/audient 2802. I’ve never heard anything mixed on a toft I liked.

Yeah, if it were just my own music, I’d have a RADAR and a modded Ghost or something. But, I need the full recall for other picky clients…“can you just turn the third guitar up a bit in the second verse?” :laughing:

But, for the record…there’s a workaround (solo exempting the return)…not the end of the world…and man, native reverbs blow compared to even old hardware. My KSP8 and PCM91 are almost a decade old, and still eat plug ins for lunch. Maybe I’ve missed some, but I’ve tried the PCM Native…and the WavesIR…and there was another high dollar one I compared…and some relatively cheap guy that someone told me they “sold their pcm91 after hearing”…apparently because they don’t know what to listen for in a reverb!

Thanks for the Focusrite/audient 2802 tip.

I’ve heard agood things about the Toft’s EQ. That and all the latency free routing to hardware is what attracts me. Couldn’t agree more about hardware reverb vs. plugs.

I hear you. I will never record with a digital cue mix again…but, you certainly don’t need anything particularly nice to do that, either. To actually do final mix, I would.

I’ve been on the fence. I think, in the end, I’m going to hedge bets a little…go with an analog summing mixer like the Tonelux OTB16, which has analog volume and pan for each channel–so, I can dedicate the last few for overdub cue mults w/the other 14 set up to sum. Obviously, I don’t cut whole live bands here, as that wouldn’t work–if that were the case, I’d be in Audient land all day–as it adds 8, supposedly really good clean preamps, multiple aux/cue systems…plus a routeable bus compressor…or either cheap out and just grab an Onyx 1640i. The little I’ve used those latest Mackie pres, they were pretty useable.

But, either way, I’ve avoided computer recording for so long…and when I listed my complaints, I realized almost all of them go away if you use an analog mixer on the front and back end–tracking and summing…potentially bus compression on it’s way back in…

Anyway, the more troubling thing to me is not that this doesn’t work…I won’t say “right”, since I suppose you could debate right or wrong…but, consistently…the concern is that it really seems more and more that Cubase is used less by professionals with external integrated gear as people who are just producing 100% ITB. I’ve now found some discrepancies with the latency compensation of external inserts–not really hugely troubling levels…but, this is just really a simple thing. What does the round trip cost? Compensate. When I freeze it in real time, it (freeze file) should null with the live signal loop. It doesn’t. This is just digital recording 101. people ragged ProTools for years for not having full compensation, but you know–theirs is now worse than Cubase…and at least if you do NONE, the engineer knows they have to figure out the latency and manually offset. Doing it, but NOT doing it 100% phase accurrate is the worst case scenario, IMO. Do it right. Don’t do it and make me bitch about having to manually do it–whichever. Don’t do it poorly and count on me never checking your work.

I don’t want to move to a TDM or HDX rig…but, if that’s what it takes to get external gear to function correctly…well, I’ll cross that bridge if I have to…I like cubase. I’d really like to see this stuff just work. Quit putting loopmash and crap dance synths into it, and actually get the external integration functioning well.

And little hi rez bugs–like I timestretched a little clip at 96k the other day…dropped it like 3 octaves. C’mon. Tried every option. Works fine at 44.1. And if I want to open a 96k project, I have to close Cubase, change my Echo from ADAT to SPDIF (even though I’m not using any digital connections at the moment)…reopen at 96k. repeat in reverse IF I need to actually use the ADAT port. That may be an Echo thing, but it’s still weird that Cubase won’t go into 96k mode as long as there’s an ADAT port on the interface.

Yes, I’ve also heard great mixes with Summing Mixers, with a stereo compressor (and/or a good Stereo EQ) on the way out of the mixer, on the way to the DAW.

I don’t cut full bands either, but I want to be able to send my Bricasti as well to each individual channel, as well as inserting some hardware compressors. So, I need something with more routing. Unfortunately, I don’t think there is a Summing Mixer that allows inserts and AUX sends/returns. There’s seems to be no middle ground between something like the Toft ATB16 ($5,499.00) and Summing Mixers like the Tonelux at $1,799.00

Seems like an opportunity for a manufacturer, if its possible, to do it for $2,500.00-$3,000.00

Except…the Toft isn’t going to equal the fidelity of the Tonelux or an API 8200. I’ve heard they’re rather noisy and low headroom…the summing boxes are literally the summing amps of those consoles.

I really think, though…if you need aux sends/rtns…and summing…you’re looking fora full blown mixer.

you do know you can hook the Briscati up digitally or analog into the Cubase mixer, though, right? I wouldn’t dream of using a reverb of that quality “just” on stems in a small format mixer. you want to be able to send any track to it…in any amount and panning (of send)…simple hookup. That’s what I’m complaining about here–that it doesn’t work the same way a plug in does in v6. But, again-simple solo exempt work around. I would advise you configure it that way. that way you can also automate the sends…the returns…EQ them if need be…it’s not like there’s a real advantage to having the Briscati sent/rtn’d on the mixer…save cue mixing…but, I’ve developed one hell of a workaround for that with plug ins, if you’re using an analog mixer for the cue signal.

Turn OFF hardware monitoring.
record enable the track with monitoring.
Adjust your send PREfader.
Turn the fader down to null.
Now, your dry is coming from the analog mixer, and the reverb is coming from the software monitoring. It’s reverb, so a little latency isn’t even noticable (since the dry has ACTUAL ZERO).

Thanks popman.

What does hooking it up the Bricasti to the Cubase mixer “through”, and “solo exempt workaround” mean? Is this different than how Cubase recommends all hardware being hooked up to work with the software?

Also, thanks for your comparison of the Toft to the Summing mixers. I have a lot of thinking to do in regard to what I want to do and my budget.

Plug in the briscati to the computer interface…either via analog IO or digital (depending on more factors in the system)…and then you go into the VST Connections and there’s an external effects tab. New…define which ins and outs you plugged it into. There will be a resulting screen where it has a button to calucalte the round trip latency–put the Bristacti into BYPASS mode…and click the button. Should result in somewhere between .5-2.5ms depending on connection.

Now it’s defined.

And depending on how you use reverb in relation to groups, you might not even need or want the “workaround”–but, it’s Alt+click on the solo button of the return channel. Makes it exempt, meaning it will not mute itself when you solo something else. So, solo a track you’re NOT sending to it…while it doesn’t mute, whatever you’re sending does…so, you hear no reverb…solo something you ARE sending to it, and you hear the track plus the reverb.

At this point, you use it the same way you would use a plug in…exception is that you now can no longer bounce offline, instead having to do it in real time–which you would have to do when using any external gear–compressor, EQ, mixer, summing amp, reverb, external MIDI instrument, etc…

Thanks popmann. Good to know the workaround.