(solution) Cubase 10.0.15 Need to manually adjust record latency with Mojave 10.14.3 and Apollo Twin 9.8.0

I need to adjust the sample offset in VST audio system (adjust for record latency) manually to -2002 by means of a test loopback signal otherwise the recording is way too early. I use direct monitoring. This does not happen al the time. If a start a blank session all works accordingly, but sooner or later I need to manually adjust the latency. Changing any of the settings in VST audio system makes no difference. Reapers, Logic and Studio One do not have this problem.

Anyone using this combo?

Figured it out!

You can not bypass inserts on the master bus (or anywhere else for that matter). Cubase wil still calculate the latency, but the FX are bypassed so the recording comes early and out of sync.
Option clicking (disabling the inserts) calculates the latency correct (or leaving them on)
A bit of a drag that this holds true for all channels…

Is this a major bug or common knowledge? Im I missing something? No other DAW has this “feature”…

This is similar to the problem with playback sync from mediabay.
As with many areas of Cubase I’m afraid the latency compensation system is only 90% finished…

29 years in the making… Steinberg should have figured that out by now :confused: I was lucky that I had a plugin with very high latency, so I noticed it early on in my session.

This has been driving me nuts for months, new computer new os new sound card new converters and couldn’t record shit with them. Really disappointed with cubase in the last couple of years, they seem to carry legacy issues with every new version and introduce some new exotic ones for your paying pleasure. Sick of it. Thank you so much for spelling this one out for me :smiley:

It would be nice if disabling the plugin, Cubase no longer calculated the latency. I wonder if there’s a reason it works that way. In these cases it seems totally broken, making disable useless.

I’ve been noticing all kinds of DPC issues. One was related to Avenger Synth, the guys at Vengeance added a new feature to fix it with in a few days. Hats off to them. Another is related to Sidechain when latent plugins are involved else where in the chain. I need to do more experimenting to be sure of the issue, to explain it properly. It might be right. The visual dipping on a dynamic EQ clearly appears out of time when a plug in adds a lot of latency to the project.

Bypass does not disable the plugin and latency is still compensated.
Disable plugins if you don’t want the additional latency.
This works as intended.

But no other DAW functions in this way….? Everything you record is out of time. Even in the manual, after figuring this out, it is not clear? It just says: “still processing”…. Latency is calculated wrong, so whatever you do don’t record with any of your (100+) FX bypassed would be somewhat more clear