[Solved] 8.0.20 Crashes on Load of My 8.0.10 Projects

Solved fixes in bold.

Knew it would.

I’m sure you’ll be fine.

I have way too many plugins.

Will report back once I track down which 3rd party offender(s) it is, this time.


Every. Single. Update.

The VST framework is simply too brittle.

These “misbehaving” plugins work in a previous version and then break in a minor update (not even a major version).

It stretches the imagination as to how that is continually the fault of the 3rd party developer.

At what point will Steinberg harden their VST container?

I realize JUCE and other plugin frameworks are, at the end of the day, just libraries running in C++ and that “anything goes,” but is there really no way?

I’m starting to think they need to do something drastic, like, load the VST plugins into protected VM sandboxes, or something.

I mean, if an entire OS can run in a VM container, why can’t a plugin?

I’d take the performance hit and memory footprint overhead, if it meant retaining recall-ablity with past projects.

I have a choice now: New version of Cubase, or forever lose recall on affected past projects. What horrible decision to have to make 3 times a year.

You know, come to think about it, I don’t think I have a single Cubase project that can be recalled, except the simplest of rough draft “starter” projects.

It really is an insidious form of not having something you once had, that is tantamount to “data loss.”

I did make a bootable image backup of 8.0.10 right before I updated. So I can revert, but why bother. 8.0.10 is not a version I can live with due to the z-order bug (which appears they didn’t fix in .20, but surely will have to eventually). May as well face the project loss now.


I moved all my plugins, every last one (after halving them) … project still crashes.

This is a first. Never seen a Cubase project file not load after doing that.

I’m not sure what to try next. I guess the 'ol prefs trashing thing…

It’s gonna be a long night.

I’ve updated to 8.0.20 and I’ve no problems opening 8.0.10 projects…

Lots and lots of crashes here :frowning:

Mac, or PC, and what are some of your major plugin vendors?

It would be nice to rule out an entire vendor as at least working on one configuration.

No issues here opening massive templates from 8.01.10.

I’m not having any problems but I’ve only tried one project so far. (Windows 8.1)

Off the top of my head, plugins used include Waves, a bit of Native Instruments stuff, some Sonnox, iZotope, Sylenth, Serum, Spire. I’ve never really had issues with old projects not loading when there’s a new update.

No problems here. I tested both old and new projects (from templates or not).

Thanks, from you sig. it looks like I might be able to rule out Waves, Softube, Slate and Toneboosters.

That still leaves a ton to investigate.

I’ll find 'em. I always do.

Thanks, I’ll add those five to my “safe” list for now.

( :blush: Yeah, I have too many plugins.)

Update: I found part of the culprit, not plugins, but one of the pref files that is clearly not compatible with 8.0.20.

Notice I didn’t say “corrupt,” because it’s not.

This is a common problem in coding. You have data (an xml file in this case) that changes and rather than add bloat to the code to “migrate” the old data to the new, you just let it break and force the end-user to start fresh.

I get it, and as a coder, I’ve done this with my own stuff.

I still need to narrow down which pref file it is. And this is with ALL my plugins removed. So, it’s possible there is another issue with a plugin incompatibility, but hopefully not.

I’ll know soon.

Just remembered there are some Slate plugins in my session as well.

FYI, all my plugins are 64 Bit apart from my Sonnox (which I have yet to update due to their upgrade fees!)

Thanks. Good, that’s twice put on the safe list then. And also good, because I have a lot of instances of VMR, VTM and VBC in the project.

(Good to know. The only Sonnox I have is Transmod.)

I also can’t help but notice a lot of really old plugins seem to always work in new Cubase versions, while many of the newer ones have issues.

Three culprits found, but still not 100% back up, so not marking it “solved” yet.

It was multiple things. Things that worked in 8.0.10 that don’t (for me) in 8.0.20.

A node in Cubase’s “External Plugins.xml” pref file (for a MIDI device) was one of the crashes.

It was not corrupt, nor malformed. Something in 8.0.20 just didn’t like that 8.0.10 created xml node anymore. I was able to leave the other nodes in the xml file untouched.

I have not recreated this MIDI device yet, so a deeper issue could still be present. In other words, it may not have been the node in the xml pref file, itself, but an issue further down the chain of execution.

The second and third issues were with iZotope RX2 and Stutter Edit. They’re now gone. Acceptable casualties of the upgrade.

[Commentary/Side bar: iZotope seems to be a company that abandons its customers by releasing whole new versions rather than fix issues. It then charges exorbitant upgrade prices if one wants those fixes. Of course every software company does this to a certain extent, some more than others. Anyway, it would seem my investment in RX is now lost in Cubase 8.0.20. The plugin is old enough that I won’t blame Cubase for breaking compatibility. There are certainly plugins much older that continue to work, so it seems likely that RX was just not coded robustly enough for the long haul. As for Stutter Edit, the last update is only 6 months old, so not sure what the deal is there. I guess I’ll cut my losses and move on.]

What’s left: I’m still not getting sound, even though I’ve checked that the audio devices are configured correctly. So, mystery to solve there.

And, I lost a ton of little window position details that are making it hard to understand what all is going on.

It would be really swell if these minor maintenance updates didn’t leave things in such a state of chaos (for those with more complex projects, I’m assuming).

Sorry hear about your issues. Why don’t you roll back to the previous version? Presumably you had managed to get that working to your satisfaction? Some of these updates are more trouble than they are worth, especially if you system has the accumulated detritus of a few years of multiple updates across many software vendors.
I always find myself spending hours doing housework tasks after many updates. Luckily for me my computer is still new - so no computer bloat.
Interesting to hear your comments on Izotope. I hope they are reading this?
I have going through a period of hyper-creativiy. I think this is because 8.0.2 has been trouble free for me. Guess I will make a restore point or learn how to roll back. I’ll let you know if I have any update issues.

Now that I’ve solved the 8.0.10 project crashing on load, I now have no sound.

I can see the meters pumping. I can see it’s going out directly to “Stereo Outs,” but no sound.

I’ve tried everything I can think of.

The VST Connections and VST Audio are setup correctly, because I can hear audio in a blank project, on “Stereo Outs.”

I reset the device, resaved the project, etc.

Update / Solved it in a strange way: Created a blank project just to get sound, then, while the blank project was still open, I loaded the large project and the sound suddenly reinitialized for it, too. I then saved the project. When I reopened it, it then worked.

Very weird.

Weirder still: opening a saved project right before this fix, that wouldn’t produce sound, now will produce sound. Somehow, that “trick” has reset something global for Cubase (or some such inexplicable thing).

Thanks. Yeah, I was about to roll back. None of fixes that would affect me were in this one (z-order bug, disable track crash, pre-fader render-in-place, cubase.exe remains after quit, crash on close, large project blank GUIs, and a few others).

I was kinda deciding to either push through and get it working, or switch to another DAW (again). Fortunately (unfortunately?) the project decided to work, just before I was about to throw in the towel. :laughing:

Hope things go more smoothly for you.

Well I am about to try after lunch. Otherwise I might have a low blood sugar moment!

The crash window on shutting down Cubase is very weird. I have gotten into the habit of closing the project before quitting, but I still get the crash window. This only happens on certain projects. I was assuming that it was plugin related. Perhaps one of the plugs won’t release memory??? So even when you close the project it is still there. However in that case surely it would crash Cubase at that point?

It’s always wise to be well caffeinated and sugared before touching a DAW. :slight_smile:

Okay, I’m back up. Everything working again. I’ve put the 4 fixes that solved my issues in bold. (That said, pretty sure no one else will stumble into my issues. These things are so system specific.)

Glad you got things sorted.

I did not have any issues - well at least so far. I always worry the something will come out of left field and go for my jugular.

These updates always seen to come when I am on a roll and I always have the internal debate - shall I. shan’t I, will I won’t I. I can resist everything except temptation.

Thanks. Well, I was too quick to cry victory. The “no sound” issues persist. I’m gonna start a new thread for it.