[SOLVED]Audio crackle new iPad 2 air running only tera synth

Hello,

New user, but somewhat experienced with DAW/PC issues.

I have a brand new iPad air 2 and just started with cubasis this week. Only a few music apps installed. No other services running in the background. Tried restarts, etc…

The fist thing I’m trying to get working is Tera synth via IAA. It works, but there is a terrible crackle when running midi out of cubasis and Tera audio back on an audio track via IAA. The processor is jumping pretty bad… I tried adjusting audio volumes, and bit rates. No major difference… Perhaps more crackling at higher rates.

When I remove the midi from cubasis, I can play the synth no problem without crackle. Repeatable issue.

Latest versions of OS and Cubasis installed.

Update: this seems to only be an issue when Cubasis is running in the foreground. I can start a midi loop via a third-party app.The crackle is only present when Cubasis is visible and showing CPU issues. However, if I keep the loop running and switch to Tara synth, the crackle issues disappear. Is it possible that this is a CPU bug caused by the GUI display?

Does your Cubasis project contains other tracks assigned to Micrologue or other apps connected via IAA or Audiobus.

In other words: Could the issue be related to the total load of apps / instruments / effects / project size?
If so, make use of the freeze function to freeze some of the instrument tracks.

Furthermore please give it a try to raise the hardware latency (Setup/Audio) to a higher value.

Hope that helps,

Lars

Hi Lars, no other unnecessary apps running. the project only has 1 track… in fact, i even get the issue when i delete all the tracks… which got me thinking what is the root issue… remember, it’s only an issue with cubasis running in the foreground. (i have 3 apps open total)

this is going to sound crazy… i fixed the issue by limiting core midi output to control signalling only. (via 3rd party midi app) so, it’s possible that you may have a bug with the core midi handler. by making only this change, CPU went from randomly peaking out to steady at 5-15%. good luck finding that one :wink:!

ps. crossing fingers on this one, but seems to be working and recording proper midi / sound from tera now.
pss. i would put a task to make your input validation for MIDI more robust… you never know what garbage other apps might be sending…

Hi dDan,

Thanks for the update.
I’ve sent VirSyn a message about the issue and shared the information with our engineers.

Will let you know once we have new information.

Thanks,
Lars

Sounds exactly like the so called"scrollview bug"that only affects Air 2 and iPhone 6.It’s a massive bug that kicks in when you reach roundabout 40-45% of cpu usage.Sometimes more,sometimes less.In simple words,graphics are interrupting audio streams and then it starts to glitch.Not all but many apps are affected by this.I can see this in cubasis as well,even when i use cubasis ONLY. Very good to notice in apps with a cpu meter,it starts to jump arround like crazy then.I was so frustrated about the purchase of Air 2,Gadget starts to glitch with just EIGHT tracks on Air 2.I’m fighting against this bug (i mean,making it more public)for months now.BUT the good story is,it will be fixed in iOS 8.3!!



Here are all the relevant infos:

http://forum.audiob.us/discussion/7624/good-news-for-air2-folks/p1

https://support.korguser.net/hc/communities/public/questions/202004840-Gadget-starts-to-glitch-with-just-EIGHT-tracks-on-Air-2-test-inside-

http://auriaapp.com/forum/viewtopic.php?f=19&t=12615&start=60

http://auriaapp.com/forum/viewtopic.php?f=19&t=12702

check the video comparison too realize how bad it is with gadget:

http://youtu.be/p9v8q9kKiXw

Hi all,

Our engineers gave the VirSyn issue a check but were not able to reproduce it.
At this moment it looks like an iOS bug.

Nevertheless please provide us with the exact repro description (step by step).
@ Crabman: If you have another repro, please throw it in as well.


Thanks,
Lars

FYI. This was fixed by iOS update. No work around necessary now :slight_smile:

Glad to hear it is solved now! :sunglasses: