(SOLVED) Can’t select multiple notes in piano roll - Cubasis 3 on iPad

I finally get a Steinberg product after 35 years! Woo!
Ok, here’s my problem…
I’ve recorded a long improvised drum track with four drum sounds, and I’d now I’d like to separate those drums onto their own midi tracks.
I selected the original first take and duplicated it 3 times.
Now I have 4 copies of the original, I want to open each one of these in the piano roll and delete three of the sounds (eg. two hats, one snare) to leave me with just one track of eg. kick.
However, I can’t select multiple midi notes using the select tool. I’ve tried with my finger, a stylus pencil, and a mouse. The select tool brings up a blue square when I draw that flashes for two seconds then disappears. I’ve also tried running the erase tool over the unwanted notes. No use there either.
In Cakewalk if I wanted to do this, I’d just click on the virtual piano key which lines up with the played key (eg G1) and it would select all the (hi hat) events on that note. Not so Cubasis.
So I hope someone can possibly help! I’m basically trying to separate four drums on one midi track onto four tracks of their own… PHEW!
Thanks and BR

Hi LouHela,

Thanks for your message and a warm welcome to the Cubasis forum!

I gave the topic a short check with Cubasis 3.4 on the iPad Pro 12.9" 1st Gen, where things work as expected.

Does it work for you, when following the exact same steps?


Hi Lars, and thanks.
I’m running 3.3.3 on a new 256g A13 iPad.

Selecting individual notes as in the video is no problem. It’s when I want to draw around mutiple notes in one selection.

I tried again just now on a fresh restart of Cubasis and it was able to select as many notes as I could draw around. Perfect! I then deselected them and tried again. Now nothing. Just this blue flashing blue square that doesn’t select anything. I closed the piano roll and then re-opened it. and success again; I could select anything. Deselect… Can’t select again.

Now another issue happens: When I close the piano roll for the third time I’m unable to re-open it by double clicking on it in the tracks pane. Indeed, I am unable to open any of the other midi tracks on the tracks pane in the piano roll.

I restart the app. and have exactly the same sequence of success and failure with the note selection issue and being unable reopen the piano roll after two or three openings.

I have no other apps running in the background.

I could possibly make a short video tomorrow when I’m near a PC. I’m still too unfamiliar with the iPad to do that! Hey, I’m old! I remember 12 of us crowding around Cubase on an Atari in the 80’s in amazement :wink:

Anyway, thanks again for any advice.

Well… Hold the phone…
Updated to Cubasis 3.4 and everything works.

Thanks again Lars.

Hi @LouHela,

Thanks for your message!
Glad to read that everything works as expected again!

Enjoy making music
& stay safe,