[SOLVED] Connection probs after IOS 10.3

I took a look at it in the App store and noticed that it hasn’t been updated since 2012. It also requires the installation of rtpMIDI in Windows.

That aside, if this supports the full Mackie Control protocol, is there a reason you’d rather use the Cubase app (since you mention DAW Remote is your workaround) than DAW Remote?

Don’t see myself spending money on an app that’s just a workaround until SB fixes the iC Pro bug, but if it offers better functionality then it might be worth the money.

iOS 10.3.2 released and PROBLEM FIXED!!! :stuck_out_tongue:
Now CuabseicPro works nice

Hasn’t solved it for me. I might try re-installing

I tried reinstalling the app - it connected for about 5 seconds then failed again. I am not totally surprised - there was nothing I have read in the 10.3.2 update that addresses the wifi issue.

I tried a variety of other things short of reinstalling the app, with the same problems.

I put full details of my attempts in the thread above that Lars posted if it’s useful to anyone else to know what didn’t work.

As I mentioned to Lars, I also have a Yamaha TF5 mixer, and neither of their iPad apps have had any connection problems regardless of iOS version, so I think there’s more going on than just 10.3.

I read your post. To be fair to the app, it was working fine before and has not been updated for some time. I gather that there are other apps (non-steinberg) that are also affected by the same problem

Part of the issue is that 10.3.2 went beta before the problem surfaced, so I wasn’t expecting a solution.

I suspect that we are looking towards iOS 11 in the summer. Depressingly!

I can see the issue from both sides of the street. As a paying customer it’s frustrating to no longer be able to use the software. However, I sling code for a living, so I also understand what the devs are going through.

In the immortal words of Homer Simpson,

“Stupid computers. Stupid Flanders.” :slight_smile:

The reason I passed along the TF app info to him was the fact that some apps are still working with iOS 10.3 while others are broken by it.

As a professional developer, this makes me think there’s more than one way to set up the network code, with the way Yamaha does it being perhaps more robust than the way the apps victimized by the iOS update do it.

Since other apps have survived 10.3 with their connectivity intact, it suggests that a coding solution is possible without waiting on another iOS version from Apple.

I suppose it depends on whether the connectivity side is modular or whether it is intrinsic to the entire app. I suspect that it is the latter since everything about using the app requires a constant update. And there is also the remote software on the host machine too.

I can connect to Cubase Pro 9.0.2 from my iPad with iC Pro/iOS 10.3.2. I have to try to connect a couple of times, maybe quit and restart the app and then it will work. Not ideal, but sort of usable.
I deleted then reinstalled the iCPro device in Cubase. Don’t know if this helped.

I cant connect with either iphone or ipad on 10.3.2 to Cubase Pro 9.0.20 no matter how many restarts and reboots! Its just broken.

Devs, did Apple actually break their programming interface for sockets or was it that Cubase IC was using a deprecated library function that Apple disabled with 10.3?

It does not work with 10.3.2 but apparently does work with 10.3.3 Public Beta.

See here:

Some people reported that 10.3.2 fixed it for them. Others (myself included) didn’t have that experience. That may be the same with 10.3.3.

I’m highly skeptical that the solution doesn’t involve application code, since none of my other network dependent apps were broken, only iC Pro.

I’m with you there. And even if connection is re-established with 10.3.3 the app will still not function properly due to the fact that it fails completely in Cue Mix mode if a Nuendo project contains a VCA fader (probably true with Cubase too).

However, that is not the subject of this thread.

I am not on the beta prog, so I will wait till 10.3.3 comes out fully.

OFI: For me with 10.3.2 it didn’t work too but with 10.3.3 it does.

Quite right, but it is ancillary info that may be of interest to many people hoping to use the app again, seeming not you, but hey, it’s not all about you (or me for that matter).

Hi all,

We’ve released a status update regarding the topic.
Please find it here: [SOLVED] News update: Cubase iC Pro connectivity issue - Mobile apps - Steinberg Forums


Dear all,

On July 20, 2017, Apple released the latest iOS update version 10.3.3 and we are pleased to announce that this resolves former connectivity issues between Cubase iC Pro and supported Steinberg DAWs.

Please follow this link to learn more: