[SOLVED] Connection probs after IOS 10.3

I updated my iphone last night to iOS 10.3

Now I can’t establish a connection. When I open iC Pro, it shows my computer, but clicking on it doesn’t work.

If I look at the iC Pro window in Devices on my windows machine, it briefly shows connected to my iPhone and then the connection drops.

I did get it to connect at one point by restarting my iPhone, but that hasn’t worked again.

Any thoughts? This has happened right at the beginning of a session, of course.

I have tried uninstalling the app and reinstalling it. It worked, briefly, but then dropped the connection. It is still listing my PC, but when I click on it, the rotating icon comes up for a few seconds, then just returns to the logon screen.

same issue here. My old iPad is still working, but my iPhone not. Even a reinstall didn"t help. I think maybe it has something to do with the new filesystem used in iOS 10.3.


Same here. The iphone connection is briefly listed in Device Setup/Steinberg SKI Remote/Devices but disappears after a few seconds.

So now, in addition to the VCA screw-up, IcPro no longer functions at all with current iPhones!



@Joss: I suggest you edit the title of your first post to include [BUG] at the beginning.

Added [bug] - thanks, Chris.

I probably should add to clarify for any Steinbergy-shaped people, it was working fine before the iOS update and I have had no other issues with my iPhone.

It’s fair to say that this bug is not of Steinberg’s making, but nevertheless it now needs to be fixed.

Good point! :slight_smile:

Hopefully this will get fixed with high priority!

Anyone know if it is working on all models of iPad?
I think that’s means iPad 4 or higher for iOS 10.

I’ve just bought the new ipad and am struggling to get it to work. It will come up now and again and works but then won’t connect next time although my pc shows up. Another problem is when it does come up the sliders don’t work. Other commands do and the meters are responding but moving the sliders does nothing. I also have an iPhone 7 on the latest IOS and this works fine. Do we know if this is being looked at by Steinberg or has anyone raised an official support request?

I haven’t raised an official support request as I’m still running iOS9 at present.
I hope someone at Steinberg can let us know that a fix will be available soon though, I’d like to update to the new iOS.

Not working on iPhone 5 on latest iOS 10 version. Same problem as decribed here.

Opened a support request about the issues with a link to this thread.
Hopefully this will be looked into soon!

That’s good. I have opened one up too so lets see how long it takes to get back to us

The same here… :open_mouth:

I spent hours to repair it without effort.
But I tried to connect IC-Pro via Connectify Hotspot… and it runs.

Just a workaround, not a solution…

Best regards

Same problem here it can see the Computer and briefly conncects then disconnects.
Anyone tried to roll back the ios to the previous one? Looks pretty risky but possible

Same problem here.

I don’t think that apple makes it particularly easy to roll back iOS and I would caution that “restore” means restore to factory setting and will involve extra work.

Not a great idea as this iOS update included a security fix for a javascript security exploit that was opening people up to hoax ransomware demands.

Just heard back from Support. Unfortunately, they don’t support that App through their department, but they said they will send a note to the app team about the issue.

I have thanked them and asked them to ask the app team to post on here so we know what is going on.

I submitted a tech support request to Steinberg about this problem earlier this week when it started happening to me. The tech support guy sent me to this forum, where I noticed that many people had been complaining about this problem but there was no response from the app developers. So I sent the following back to the Steinberg tech support guy.

Maybe if we all do something like this, we’ll manage to light a fire under Steinberg and get something to happen.

It’s starting to look to me like Steinberg, after selling this app to me, is in the process of abandoning it and shunting its customers off to a forum that no one from the company pays attention to where we can uselessly complain to each other about how Cubase iC Pro doesn’t work anymore.

This is not the kind of treatment that I expect from Steinberg. I have devoted years to learning to use Cubase (currently updated to 9 Pro). I did this in part because my image of Steinberg was that I could rely on them to support their products. I’m not seeing anything like that in this current situation, and I’m not happy about it.

Part of the blame is on Apple for breaking stuff with another update. VSL support for the Audiobox 1818 had to be abandoned by Presonus because of changes they made to OS X. However, Steinberg does:

  1. Need to support this product or refund the cost since it is a paid for product
  2. Stop pointing fingers at other parts of your company. I understand it may be a different group from the primary Cubase developers but it’s still one company and it’s unprofessional to show internal finger pointing to customers. To me, Cubase iC Pro is a part of Cubase and I don’t care who in Steinberg fixes it.