SOLVED:Crossfade editor window off screen

Cannot get crossfade editor window back on screen. ‘Force Windows Visible’ has always worked for other instances but not for this window. It doesn’t show up in list. Tried lowering screen resolution but that didn’t seem to work either. It’s stuck at top left. Almost all little edit windows seem to pop up here and I have to use ‘FWV’ to pull them back.

Please, any ideas would be greatly appreciated as I seem to be screwed without it.

Could this be an issue with ‘Maxivista’, Cubase, or me just being an idiot?

Would using my last PCIe low profile slot for dual monitor card stop the problem or is this just inherent of dual monitor use in general? Getting severely frustrated! -Computer

HP Pavillion Slimline
Maxivista
Cubase 5.5

Advance thank you!
Crossfade Editor off screen.PNG

Is it possible to right-click on it and de-select Always On Top? Trashing Prefs may be a last resort fix.

have you “disabled” the second monitor and tried to grab it ?

regards
john

Thanks for replies! Found that scroll bars @ bottom right of main screen allowed the window to be visible. All better now. :smiley: