SOLVED Cubase 10 - doesn't install new content

I have downloaded Cubase 10 and I’m running the installer.

When I get to Content I get this pop-up window saying:
“Steinberg Library Manager is trying to install a new helper tool. Type your password to allow this.”

I type my password and click Install Helper.

It only results in a new pop-up window saying:
“Failed to establish privileged helper!
Please get the latest Steinberg Library Manager and reinstall!”

If this solution is to install the “latest” Library Manager, where do I get it? Can’t find it on
Your good peoples help is indeed required at this point.


I would say you have no permissions to write to the folder. Try to change the permissions manually, or try to run First Aid (Repair Disk Permissions) from the Disk Utility.

Thank you Martin.
Yesterday I changed the permissions for the “old” Library Manager (thinks its called Halion Library Manager?) manually but still got the same message. I can try the Repair Disk Permissions later this afternoon. Whatever you suggest, I’ ll try it.

Still no progress and I’m open to suggestions.


I tried to search on Google. It seems to be more on mac side. Maybe try this?

Thank you Martin. I will have a look when I get home this afternoon.

  • Check for any log messages in the Console App. I have myself come across this where the SMJobBless api failed with internal error and looking at the system log message helped.

  • Manually remove your helper app from the /Library/PrivilegedHelperTool Folder and retry the installation.

  • The Console App is beyond my knowledge.

  • I did remove what was in the folder, which contains one Microsoft related helper tool + one Native Instrument related helper tool. I also removed the whole folder but none of this did change anything and the same messages kept popping up and no content was installed.

I have created a support request but while waiting for their reply I will investigate further. Is it likely that a clean install will help on this problem?
I welcome anyones suggestion what to do next in order to get Cubase 10 up and running with all the new content.

…and then my dongle broke down :open_mouth:


In case someone has a solution or a suggestion.
Attaching a picture of the error message.

Solved after installing the Halion 6.2.10 update

I have this issue too sinche christmas.
I’ve bought absolute 4 and can’t install ANY of the contents
I’m on sierra and latest halion.

Pls help…


Do you have the Steinberg Library Manager installed, please?

Hi. I am having this issue. It is infuriating. Latest Catalina - new install. Library Manager is installed and latest version. I’ve tried everything I have found in the forums. Nothing is working. I had issue before fresh install - and same issue since fresh install. I have been having such issues since 10.5.10 and 10.5.11


Could you try to trigger First Aid from the macOS Disk Utility, please?

I solved this by installing older versions of Library manager on top. Apparently the new one doesnt work