<SOLVED>Cubase 8.5 audio drag and drop not working?

Can anyone else confirm or is it just here?

I can drag and drop audio files (either mp3 or wav) into the arrange page of 8.0.30. It works reliably and copies the file into the project audio.

In 8.5 this no longer works, I have to go via the import dialogue which is a pain. Can anyone throw any light on this behaviour please?


From where do you drag the file? MediaBay, Pool, Explorer…?

From desktop, or any open folder (Windows 10 in my case). This has been a feature since around C4 I think.


Open Cubase 8, create test project.
Open any folder containing audio files (not zipped)
Drag, drop into arrange page
Result is that files are copied to project audio folder and into arrange page (multiple audio files start an extra dialogue option to copy to individual audio tracks).
Close Cubase 8

Open Cubase 8.5, create a test project follow same routine, audio cannot be dropped.

edit: Drag and drop works from Media Bay

Drag and drop works perfectly for me.
Cubase Pro 8.5 on Windows 10 pro 64bit.

Did you hover your dragged file over the cubase icon on the taskbar to bring cubase into focus?

Mm, thanks fretthefret, glad it’s ok there, useful to know. It’s a worry here though. Messes up my workflow at times

It makes no difference if Cubase is the focus or not - it just doesn’t work anymore. Using C8.0.30 it works perfectly with identical movements, so something has changed. I agree that window focus may be involved. Another thought is that maybe I have some windows permissions screwed up. I’ll have a look at that.

All windows security permissions are ok.
Imports work fine via dialogue or from Mediabay or Pool, it’s just from sources outside Cubase.

I have tried disabling preferences on start up, no change in behaviour. I confirmed also that I am opening C8.5 as Administrator

All ideas welcome

Also works, here.

When you drag the file over the Cubase Project window, can you see the + cursor, which informs you, you can drop the file here?

Can you drag-and-drop from desktop to the Pool?

I had this before, had something to do with having Cubase run as administrator. If you run Cubase as administrator, then you cannot drag/drop into it from explorer. So you must disable administrator on Cubase, if I remember properly.

Brilliant sonic state!

Ran program having removed Administrator status = problem solved

Thanks all

This has been like this since at least C7 as i was having the same issue then, if i don’t run as admin though i get the occasional issue with Arturia V collection not recognising my Arturia licences… bit of a pain but not a major issue.

Dropping 24bit samples into a 32bit project timeline from Mac os 10.10.5 finder results in Cubase crashing every time :frowning: Has been working in C 8.0.x… Any suggestions?



It works to me here (Mac OS X 10.11.2). Could you please be more specific? Where do you drop the file? To the Project window or to the Pool? What is your settings in the Import Options dialog? What sample-rate do you use? Mono/Stere/5.1… file?

  • 32 bit project
  • 24 bit stereo file
  • dropping the 24 bit file on either project window/timeline or pool makes no difference
  • most of the time Cubase crashes before i can choose any import options, but i woul choose “copy to project and convert if necessary”


I cannot reproduce it on my Mac OS X 10.11.2 with the file, I exported.

Did you export it from cubase? I chose a file that wasn’t known to cubase before, if that makes any difference.
Also, my OS version differs from yours.

Yes, I exported the file from Cubase. I will try this. And yes, I have different OS version.

I’ve been having this problem since I upgraded to 8.5.

Just tried turning off “Run as Administrator” to see if it helps, and, yes it works, but JBridge no longer works. Grrr!
Anyone have a workaround for this?

Just contact jstuff.wordpress.com and he will send you modified installer where warning wont pop up. Make sure Cubase and Jbridge (jbridger.exe, auxhost.exe etc etc) are not run in Administrator mode.


thanks, I’ll try that

Did you manage to solve this? I too have the same problem, I wan to to run Cubase without admin priv. but then jbridge doesnt show gui.

yes it all works fine now. follow Grada’s suggestion and contact jstuff.