[Solved] Cubase 9 and Sync-Gen II Pro problem.

So I haven’t used my Sync-Gen II Pro with Cubase 9 Pro and today when trying to calibrate the sync offset it doesn’t work. My measured latency of 127 samples won’t be compensated whatever I do and I’m thinking I’m getting tricked by Cubase latency compensation and/or the asio guard or something.

My setup is pretty basic, same as I used in Cubase 8 and that worked just fine. Output channel 3+4 in cubase is connected to the Sync-Gen II Pro. I’m using the “Sync-Gen II Fx” plug-in on the insert channel.

The “Sync-Gen II Efx” plug-in, the one generating pulses for the hardware Sync-Gen box has latency 0 when looking in the Cubase plug-in Manager, just like it should. This is what cubase uses for latency compensation yes?

Anyone have any guess what I’m missing here?

Ah… shit I’m getting tired of this now. Whatever I do recorded audio is 109 samples (2.4ms) late.

I’m doing something wrong but I can’t for the life of me figure out what.

There’s so many things to tweak and try in different combination that my head is about to explode. (Sound card latency, asio guard, record shift, adjust for record latency + the settings in the sync gen plug-in.)

Hm, difficult question. I can’t help you with that :frowning:
What is doing this Sync-Gen II Pro?

I’ve contacted innerclock systems so I’m hoping for some confirmation if it’s something that happens in Cubase 9 Pro.

Found a workaround and that is to setup the Sync Gen II Fx plug-in on a instrument track and set the cubase track delay to -2.4ms.

Did you disable asioguard for all sync gen plugins?

Yes I’ve tried both disabling asio guard completely and also disabling it explicitly for just the plug-in.

Updated to Cubase 9.5 and the Sync-Gen plug-in I still not behaving correctly. Didn’t manage to get any response what so ever from Innerclock Systems.

Anyone here using Sync-Gen in Cubase 9.5?

Yes I am,
I’ve first recorded all synths without the syncgen and put their offset in external instruments (all around 4-5ms)
Then I activated sync gen and got around 882 samples ahead and everything records perfectly on the grid.
Please make sure you’ve

Defined external instruments
Defined external midi devices
And LINKED the device ports to the external instruments, otherwise it won’t work.

Ok thanks Raphie, I’ll try your approach.

Ok, now I’ve tried every possible setting under the sun and still, for whatever reason the offset on the plug-in does not do ****ing anything. 138 samples advace, 4000 advance, 4000 delay all gives no difference at all.

Update: I’ve got everything working now. So what did I do? Well my DAW had some serious problems updating to the “Windows 10 Fall Creators Update” and then I decided to just start all over all nice and clean.

With everything fresh and newly installed the InnerClock plug-in generating the audio pulses to the hardware started to behave as it should! :smiley: