[Solved] Cubase/Stulus RMX - Issues with Drag n Drop

Hi guys,

I haven’t used Stylus RMX in Cubase for quite some time, but now when i try to I can’t get it to work properly. Everytime I try to drag a MIDI-file from Stylus’s GUI is just springs back and won’t show up in the Cubase’s arrange window.

I have tried messing about with the settings for MIDI-film-import but haven’t been able to solve is.

Any ideas?

You have to drag a part to the first midi track in Cubase, assuming you have 8 midi tracks for the 8 Stylus channels. So if you’re dragging the third part in Stylus to Cubase, you need to drag it to midi track 1, and then it drops on track 3 on mouse release. It’s a fairly weird system, but it works.

What’s annoyed me for years is that this process also renames a track further down the window to SysEx. First world problems etc.

Do you guys use the RMX with or without ASIO guard?

I´m having some issues with Spectrasonics stuff

Thanks noiseboyuk!

That solved it. I think that I’ve tried to use “Instrument Tracks” and that might be the reason that I didn’t get it to work.

I am having this same problem. I drag the MIDI file to a MIDI track, and it looks like it wants to do it, but then when I let go of the mouse button, the MIDI file disappears and the file doesn’t stick. It started when I upgraded to Cubase 9.5 and my Mac Book Pro (2017) to High Sierra. So I can’t figure out which one of them caused the problem. I haven’t been able to figure out how to resolve this. This is a feature I use all the time. I have been resorting to playing triggered loops to get around the problem. But that is very limiting and would prefer to have the MIDI to edit. I hope someone is still monitoring this thread and has some ideas on how to resolve. I hope its a stupid setting somewhere in Cubase or Stylus. Any help is greatly appreciated.

Its as the reply above. You need 8 midi channels in Cubase, and always drag a midi clip from Stylus to Cubase midi channel 1 - it will then drop to the correct channel. If you are on, say, Stylus track 6 and you drop it to Cubase channel 6 it will vanish into thin air as it’s trying to put it on 6+6=12, which doesn’t exist (sometimes I think it will create a new midi channel not connected to anything)

It’s an odd system, and I still get glitches where it names other tracks in my session with SysEx. But once you know, it’s all liveable with.

So weird. I followed those directions outlined above and still no luck. Went into the Preferences to ensure the MIDI import setting are correct. (https://www.spectrasonics.net/support/knowledgebase_view_topic.php?id=326&categoryID=14) So frustrating. I’m sure it’s something simple, but I can’t think of what it might be. I’ll keep researching. I’ve been trying to avoid calling Spectrasonics and sitting on hold for ever… lol

I’ve found their email support very good, Reese… good luck!

I found if your using Stylus RMX as an instrument track, no matter what the preferences are, when you drag, it always goes to the bottom of a project. If you drop on a midi track all is well. I’m not sure if this is a bug or not but it’s frustrating, hence I always use midi tracks routed to the RMX instrument track.

To use MIDI drag and drop in cubase, it is important to go to (Cubase) Preferences–> MIDI–> MIDI File" and uncheck “Import To Instrument Tracks” and uncheck “Auto Dissolve 0” .Then you can drag and drop where you want.

True, but that doesn’t work for instrument tracks.

I did do that. but still no luck. I’ putting a call into Sprectrasonic. Will report back to the forum when I hear back from them.

On my system this is also working for instrument tracks. Did you restart after changing the preferences ?

Not on instrument tracks. I can change all Midi File preferences and nothing changes the fact that it always creates a new midi track.

I attached a png file from my midi file preferences. So i can drag and drop on all tracks including instrument tracks. They are in German ,but easy to translate in english ( same place ). Before i did change the preferences i had exactly the same problems as you now.
midi file preferences.png

OK, I copied your settings exactly and still, when I try and drop a Stylus RMX (same thing with Superior Drummer 3) loop onto the instrument track a new midi track is created.

Worked for me. I’m dropping stylus tracks into a midi track which is “tied” to the stylus instrument track - does that make sense? Thank you tini for figuring that out. How you came to that conclusion IDK. I’ve been struggling with this issue for YEARS to the point where I haven’t used Stylus for years - tracks jumping all over the place, creates unwanted new tracks at the bottom of the project, much frustration. Thank you!

OK, I FINALLY figured it out. Midi (and Instrument) tracks have to be set to “musical mode”. Is ther a way when adding tracks to have this set to default?

I found the answer for others looking,
Editing/Default track time type dropdown.