SOLVED: Cubase suddenly expects wrong path for some VSTi

I have both Cubase 8 and Cubase 6 installed on my Windows machine, and I confirmed that both of them have this problem with some of my projects.

I have songs that use SampleTank 3 (64 bit), some use a single instance of it, some multiple. Until today the VST was correctly loaded. But suddenly when I open some of the songs I get an error message saying that SampleTank 3 is missing. And when I check plugin information I see that some tracks have plugin information for SampleTank pointing to Cubase application executable instead of “SampleTank 3.dll”. This is pretty weird.

What is also weird is that I get this error for songs that I didn’t modify lately, so there is nothing in the project file that’s changed, it must be some global misconfiguration that applies to all 64 bit versions of Cubase (I have 6 and 8, both fail).

If I open Cubase 6 plugin info, I see reference to 2 SampleTank 3 VST plugins:

SampleTank 3 / IK Multimedia / SampleTank 3.dll / C:\Program Files\VstPlugins / Instrument / / VST 2.4
SampleTank 3 / Steinberg Media Technologies / Cubase6.exe / C:\Program Files\Steinberg\Cubase 6 / Missing Instrument

If I open Cubase 8 it only shows the first (correct) reference but it fails in the same way.

For some songs I don’t get this error, then only correct SampleTank reference is displayed in Plugin info.

For my projects it’s close to catastrophe because tracks with missing plugin info contain custom parameters and if I re-select the plugin all parameters are lost. So there is no way to get the parameters unless I fix the plugin path.

I am completely clueless about how this happened, frantically trying to find the solution.

I managed to resolve this issue, here’s what caused it in case somebody experience a similar problem.

SampleTank has both VST2 and VST3 instruments, so the fact that some tracks with ST instances worked but other didn’t was due to them using different VST versions. VST2 instruments were OK but VST3 didn’t play. What happened was that a file from SampleTank with VST3 instrument definition was somehow missing in the VST3 folder (it must be of course me who lost it in attempt to resolve unrelated issue). So Cubase didn’t manage to locate an instrument file for ST VST3 tracks. When Cubase 6 fails to find a VST3 file it replaces its path with Cubase.exe in VST information page, this is what confused me. Cubase 8 is smarter and simply removes the failing VST instrument from its list. But since there 2 SampleTank instruments (VST2 and VST3) and one of them was listed I was under impression that SampleTank is OK. What helped me to resolve this issue is that I had Mac with Cubase AI where I loaded the same song and saw in the VST info that there were in fact 2 different VSTs for SampleTank. So I repaired my Windows ST installation and everything was OK.