[SOLVED] Cubasis 2 iTrack Dock Compatibility

I’m using Cubasis 2 on iPad Air with latest iOS and Focusrite’s iTrack Dock. I’m loving the iTrack because it seems the tidiest of interfaces and the sound quality is stunning. My issue is, that if I plug an instrument or microphone into the dock, and open up an audio channel to record on in Cubasis 2, the software receives no signal input and will not record the sound that the iTrack is receiving. It used to, when I first bought the iTrack. If I go to audiobus, open some software like JamUp for instance and send that to Cubasis 2, then it works - and records beautifully. So, I do have a work around. But at the end of the day, it’s not quite right. The hardware hasn’t changed so I can only figure that either a Cubasis update or an iOS update must have changed things. Has anyone else had this problem? I’ve been feeling like it’s me, like I’m missing something obvious, but I’ve tried everything I can think of.

I’m determined to take this iPad recording thing as far as I can - I really think there’s a great future in this. I just need to iron out these kind of compatibility niggles to improve my workflow. Like, recently I realised that I had to abandon JamUp. Positive Grid no longer support it and it has stopped functioning properly in Cubasis 2. That’s a little irritating since I bought all the in-app stuff - but onwards and upwards. Positive Grid don’t care so theres no point buying their stuff anymore. I think I’m going to try Tonestack.

Hi Jamie,

Thanks for your message.

Please have a look at Cubasis LE tutorial (at around 1:45 min.) to learn how to route audio tracks to a connected audio device:

If the problem persists, please get in touch with our friends at Foucsrite.
We’re at hand to provide them with a Cubasis promo code for testing purposes, if required.

In regards to Positive Grid / Jam Up:
Are you sure that the app is no longer supported? From what I’ve seen, Positive Grid has just released a new update end of May.
Also other users have reported that the app works fine with Cubasis 2: https://www.steinberg.net/forums/viewtopic.php?f=183&t=128494
Same here, I’d suggest to get in touch with them directly, to check the current status.

Hope that helps and please let us know how you proceed!


Hi Jamie,

I did some iTrack Dock tests with :

iPad air 1 + Cubasis 2.4/2.5, iOS 10.3.3
iPAD Pro 10.5 + Cubasis 2.5, iOS 11.4

  • connect the iPAD to the iTrack Dock
  • connect instrument to the iTrack Dock instrument input 1
  • up the input gain on the iTrack Dock to get an input signal on monitoring
  • launch cubasis and create an audio track
  • activate on audio track record enabled and monitoring function
  • play on instrument
    Result : cubasis mixer metering show the instrument input signal
  • start the record mode on cubasis and play somthing on the instrument
    Result : instrument signal is recorded as expected, recording file was created, cubasis recording with iTrack Dock works as expected.
  • stop recording and start the cubasis playback mode
    Results : all cubasis tracks and recorded audio files are audible on the iTrack Dock Monitoring output 1.

Sorry, i can’t confirme your iTrack Dock issue.
All iTrack Dock instrument input signals are recorded and played back in Cubasis as expected.

best Jan

Thank you Lars. I’m not a beginner. I’ve been using Cubasis 2 for months now and have been recording music professionally for many years. I did however, look over the video and I can’t see that I’ve missed anything. As I’ve said, it used to work fine anyway. I’ve already contacted Focusrite and they have been incredibly helpful, but I think we’ve established that the iTrack Dock works fine as it works exactly as it should with Auria and GarageBand. No problems recording in either App.

When I open JamUp as a send on a clean guitar channel, it adds itself as a send in every other audio channel I have in the project. However, the clean guitar does send out to JamUp and sounds fine. I can mix this down and import this audio and work with that so I can get rid of JamUp and the issues it causes. But this is not exactly how it is supposed to work. Also, I should be able to add an audio channel, go to routing, inter app audio - open JamUp and record the effected guitar to a new audio channel in real time. Sometimes it allows you to set this up but the audio is distorted. Sometimes it makes Cubasis 2 crash. But usually, you add JamUp to routing and it just vanishes from the clean guitar send, rendering it useless. If you try to occupy the send again, Cubasis 2 gives an error message and the communication between DAW and plugin is lost and the whole thing needs restarting.

I have contacted Positive Grid by e-mail, Facebook messenger on different pages they have, the Facebook group, and gave them a bad review for the app. They haven’t responded to anything and other people who use JamUp with Cubasis 2 say that positive Grid stopped trying to fix these issues a long time ago and stopped replying to any messages or criticism about it. Whilst it does still work in some ways, it doesn’t do exactly what it should and if they’ve abandoned these issues in favour of the new software then it’s just morally wrong not to offer a discounted Bias to JamUp users as a bit of an apology.

I’ve made a rough video of the issues I’m experiencing and if you’d like I can send it you - if you just let me know where to send it to.

Thank you Jan. I can’t tell you how much I appreciate the lengths you’ve gone to here. I have followed your instructions to the letter. I have also reviewed the tutor video as suggested by Lars, please see my reply above. It still does not work for me, but as I have said before, it used to. I notice that although the iPad Pro you have used in the test is on iOS 11.4, the iPad Air 1 is on iOS 10.3.3 - and mine is on 11.4 - that’s the only difference I can see and I wonder if that might in fact be the problem. iOS 11.4 may just be a little too much for the iPad Air 1. I have certainly noticed that it has slowed a little.

Could I also ask please, how have you tested the Dock with an iPad Pro? I thought they didn’t fit the Dock. Just curious, as I’d love to get one but this Dock is excellent. Just, not in cubasis at the moment.

Hi Jamie,

Thanks for your feedback.

Up front, it would be great to receive your video, which might be helpful to better understand the full issue you encounter.
Please upload the video via WeTransfer, Dropbox or similar and provide the download link via private message.

In regards to using Cubasis with the iTrack Dock, please run the following test:

1 - Please launch Cubasis and load an empty project
2 - Completey power down and restart the iPad

Further steps
3 - Once the iPad is restarted, launch Cubasis
4 - Run the iTrack Dock recording test exactly to Jan’s description above
5 - Make sure to use the empty project mentioned above, do NOT use any inter-app audio plug-ins this time

Please note that using inter-app audio plug-ins can lead to several issues, as described within this forum article.

For now, please let us have your feedback, if the iTrack Dock works as expected and matching to Jan’s results.
Afterwards we can separately discuss the JamUp Pro issue.

Best wishes,

Hi Jamie,

I did an new test again with the iTrack Dock, iPAD Air 2, iOS 11.4 + Cubasis 2.5

I can’t confirm your iTrack Dock / Cubasis issue.
Recording in Cubasis works as expected.
Also with the “FX Pack 1 Stereo Delay” as assigned send effect in the recording track
You can see it in the video, which you can download under the following link within the next 7 days.


It looks like that the iAA send effect is your recording problem.

Could I also ask please, how have you tested the Dock with an iPad Pro?

I use the iPAD Pro 10.5 not the iPAD Pro 12.9.
The iPAD Pro 10.5 is compatible to the iTrack Dock which is almost the same size as the iPAD Air 1+2


Hi Lars!

I’ve sent you a Dropbox link to private message. I made the video last night.

As soon as I am able today I will do another test exactly as you suggest and I’ll try and video it. Then, if I’m doing something wrong then you should be able to see what it is.

Thank you for your continued help, you guys are amazing.

Best Regards,

Hi Jan. Now you’ve told me that the dock will fit the 10.5 version I want to buy one! Would you believe, I almost didn’t buy the dock because I planned to upgrade to a pro. Then, I tried it and loved it and bought it anyway. So, I sent an e-mail to focusrite to ask if they were going to make one for the pro. They said it no they weren’t going to make one, but never mentioned the dock would fit the smaller one! Haha!

I’m going to do another test as soon as I can today - as per my reply to Lars above. I’ll let you know what happens.

Best Regards,

Hi Lars,

I ran your test last night. Still no success. I’ve sent you a video of the process in a private message. I can’t think what to do next. Is it worth uninstalling and reinstalling Cubasis 2?

Best Regards,

Hi Jan. I did a new test as per the instructions from Lars. Still no success. I’ve sent him a video of the process. Do you have an iPad Air 1 with iOS 11.4 that you can run the test with? Or shall I try uninstalling and reinstalling Cubasis 2?

Later, I might be able to borrow a new iPad 9.7 2018 to run the test with to reassure myself that it’s not me being stupid. Haha!

Hi jamie,

I’ve done more tests with:

  • Air 1, iOS 10.3.3, Cubasis 2.5, JamUpPro, iTrack Dock

  • Pro 10.5, iOS 11.4, Cubasis 2.5, JamUpPro, iTrack Dock

  • Make sure the JamUpPro microphone access is enabled.

  • Shut down the ipad, it’s gotta be off.

  • restart the ipad

  • start JamUpPro and play in the instruments input from the iTrack Dock
    Result: iTrack Dock + JamUpPro metering show an input signal

  • start cubasis with a project without iAA allocation

  • create an audio track and assign it to the audio routing input iAA/JamUpPro

  • activate recording on the audio track

  • play your instrument and check the input signal in the Cubasis mixer
    Result: input signal is displayed in the mixer and the instrument is audible with JamUpPro sound

  • start recording and stop recording after a few beats
    Result: the instrument was recorded with JamUpPro sound, recording with iAA in audio input routing works as expected.

please see the videos which you can download here within the next 7 days :


I can’t update Air 1 to iOS 11.4 because I still need 10.3.3 to test it, but I’m sure it’s not iOS 10.3.3 or the Air 1 on your side

Hi jamie,

Do you ever use JamUp in Cubasis to record the re-amped sound back in on a new audio track or
do you just mix it down and then pull the new wav back in to a new audio track?

How do I add a distorted JamUpPro sound to a clean guitar sound?

You do a loopback routing, but that’s not necessary.

It could be easier.

  • create an audio track with a clean acoustic guitar audio file
  • insert JumUpPro as iAA insert plugin
  • choose in JumUpPro your e.g. distorted sound preset
  • start playback
    Result: the clean guitar now sounds with distorted JumUpPro sound
  • press the freeze button on the track, to the left of the record enable button
    Result: A new track is created and the distorted JumUpPro sound is rendered into the clean acoustic guitar audio file.

see the video which you can download within the next 7 days:


best Jan

Thank you Jan. You have been amazingly helpful. I didn’t realise I could get the audio so easily by freezing, thank you so much for that tip. What a guy! I still have the same issue with the dock input not coming into cubasis but I have a list of things to try. I just need a little time to Myself without interruption to try and nail it down. Hopefully tonight!

Hi everyone. I am over the moon and slightly embarrassed to inform you that I have resolved the issue. Microphone was disabled for Cubasis 2 in the iPads settings. Corrected this and it all now works perfectly. I’m embarrassed yet pleased that it was so simple an issue. Can’t thank you enough for all the help you’ve given me, it has been invaluable. I have no hesitation in recommending Steinberg and your software to anyone and everyone.

Now, to get to recording!

All the best,

Thanks for the update, Jamie!
We’re glad to hear the issue could be solved!

Have great fun and enjoy using Cubasis!