[SOLVED] Cubasis 3 doesn't work with Airpods Pro

I’m brand new to Cubasis, so it’s taken me a few days to verify that I wasn’t missing something, but I finally figured out that the built-in sounds (and all audio output in general) work just find with wired headphones, but the results are pretty awful with AirPods Pro. I use AirPods Pro almost exclusively, so it took me a few days to try another type of audio output. As soon as I did, I was pleasantly surprised that all the audio sounded great. But, with AirPods Pro (I have not tried the original AirPods), the sound was distinctly low-quality, as if it were coming from 8-bit, 22khz samples. And intermittently, tracks played back at about half of normal speed, and were not synced with the graphical updates on the screen.

I’m very happy to know that there is a simple workaround (used wired audio), but it would be nice if the AirPods Pro would eventually work as well with Cubasis 3 as they already do with other synth apps.

–Kris

Hi Kris,

Thank you for your message.

Please use the following steps to use Cubasis 3 with the AirPods Pro:

  • Please connect your AirPods Pro to the iPad
  • Launch Cubasis and go to Setup/Audio and enable “Bluetooth / AirPlay” by tapping the corresponding button

If the problem persists, please go to Setup/Project and choose (or reselect) the matching sample rate of your project.

On a side note:
Please note that connecting wireless headphones bring lots of system-related latency, which will make it hard to record instruments in real-time.

Please let me know if this helps to solve the issue.

Thank you,
Lars

Hi Lars,
Thank you, this does solve the problem. I had already tried each of those settings before, without success, but it was the combination of both that did the trick! And yes, I will use wired audio whenever possible, but for “on the go” use, the AirPods are quite handy. I’m glad to be able to use them now. Thanks again!

Hi Livingstudios,

Glad to hear this, thank you for the update!

Best,
Lars