[SOLVED] Cubasis LE 2 stays in demo mode even when connected to compatible device

Cubasis LE 2 stays in demo mode even when connected to compatible device.

iPad, 6 generation iOS version 12.4.1, connects to new Yamaha THR II 30 device. It shows as connected in Cubasis LE & Bluetooth Device Connection in iPad general area.

Instructions say once connected it will switch from Demo mode, but it doesn’t. Only gives start demo option, can’t save and closes after 30 mins.

I checked my account in this site and it lists the Cubasis LE software as being activated, but it’s not activated in the software. I can’t find any information with any other method to get it activated. Anyone have some advice?

Hi all,

Please follow these steps, to unlock Cubasis LE2 with your Yamaha THR-II series device:

(1) Please launch Cubasis LE.
(2) Please connect your THR-II device to the iPad, using a USB cable and the Apple Lightning to USB Camera Adapter*.

After a short moment the message “Cubasis LE Activated” should appear.

*If you own the latest iPad Pro model, please establish a connection between your THR-II device and the iPad via the USB-C Digital AV Multiport Adapter or the USB-C to USB Adapter.

Best wishes,

Hi Thanks for the info.

I don’t have the correct adapter, and the Yamaha amp didn’t come with a usb cable. I have a couple questions.

The instructions say that the activation will occur when the compatible device is attached via blue tooth. Since getting rid of cables is the main reason I bought the Yamaha amp, this defeats the purpose if I need to cable it up for the activation to work.

Will this Bluetooth activation issue be fixed?

Once the activation occurs via cable will it remain activated or does it need to be tethered with the cable for use at all times?

Does the iPad connection to the Yamaha THR II 30 device charge my iPad while connected?

Since I need to buy cables and adapters now can you specify exactly what I need to buy? I have been looking up iphone/iPad connection kit, there are lightning to usb 3 adapters is this what I need or is it limited to usb 2?

I have an Alesis iodock but I can’t connect that due to the usb connection ports.
Pretty silly that the activation does work over Bluetooth as advertised!


Hi tonyscotthao,

Currently, unlocking the THRII series amps work via cable connection, which should be explained in the instructions coming with the amp.
Otherwise, please have a look at the instructions stated above.

For the initial support of the device, Yamaha made the decision to not support Bluetooth to unlock the Cubasis LE feature set.
However, it is planned to release a Cubasis LE 2.8.3 update at the end of March 20, which will support the LE feature set unlock of the THRII series amps via Bluetooth. The same date, Cubasis LE 3 is planned to be released, which same way will support the amp series.

Normally, it is only required to connect the supported device once, to unlock the Cubasis LE feature set, except for the case of reinstalling the app.

In addition, here is the link to the Cubasis LE Compatible Hardware list, to learn more which devices can be used to unlock Cubasis LE from demo mode.

Please get in touch with Yamaha regarding the remaining THRII related questions.

Hope that helps.


Hi Lars,

Thanks for the additional info. I was able to locate an apple Lightning to USB Camera adapter. I live in New Zealand so had to go to five stores before I was able to locate one $52. I connected with a USB cable I found with the correct connections and the activation appears to have worked, there was a message stating it was activated.

Still the app says it’s in demo mode, when I look at the Shop link in Cubasis LE, it says Registered FREE. I am assuming it is activated since it hasn’t closed the demo after 30 minutes. Seems a little unstable it crashes As I record tracks. I look forward to the next release it may be more stable with the Yamaha device? At this stage, I don’t feel it’s very useable due to the various issues I am encountering.

BTW, while connected with the USB to lightning adapter the iPad doesn’t charge. I’ve had to connect it a couple times because I wasn’t sure the activation stuck due to Shop status.

Thanks for your help none the less. :star::star::star::star::star:

Hi tonyscotthao,

Thank you for your message.

You’ve successfully unlocked Cubasis LE since you’ve seen the pop up message, after connecting a compatible device.

In addition, you can choose to register your Cubasis LE app version and get a free RoomWorks SE plug-in via the Cubasis LE in-app shop.
This is unrelated to the Cubasis LE unlock procedure.

If you encounter problems using the app, please file a detailed bug report with a short step description, to allow us supporting you.