[SOLVED] Cubasis Record/Play of Genome patterns : BUG!

Hi,

Recently purchased Cubasis, so will assume some finger trouble…however…

I am having issues doing two things…
a) Playing a drum sequence from genome through Cubasis built in drum kits.
b) Recording a pattern from Genome into a midi track.

for a)…

  1. Open Cubasis, insert a drum kit into a midi track
  2. Open genome, make simple boom/tst pattern of kick on 1/4 notes, and hihat on 1/8 notes
  3. swap to Cubasis connect to genome as input in midi track
  4. swap to genome and hit play…
  5. Result…you only hear the hihat… delete a hihat from the sequence on the beat and you hear the kick, add the hihat back and you dont hear the kick… place any other hit in the sequence and you hear only the last hit(note) placed in that location in the sequence.

Run the same Genome sequence using a drum kit in alchemy, or music studio and you hear the pattern correctly. connect to a PC using ext midi and again, you hear the sequence correctly.

for b)
Do all of the above and hit record… the pattern is not correctly recorded.

Please let me know if i have missed something here… but this is kinda a big deal to me… thx

Try remapping Genome to a different octave. Sometimes Genome and other apps don’t agree where C0 is located. This is a very odd problem with Genome.

Hi,
thanks for the suggestion, and i appreciate the heads up as you are right that C3 on genome is actually C2. (note 48) but its not a note number assignment in this case… …playing kicks alone works fine, but when coupled with the hihats, or any other note, the drums in Cubasis respond to only a single hit in any time slot…very VERY frustrating…

Playing Genome to other sound sources there seems to be no issues, so am hoping that someone on here uses both apps and can either guide me in the right direction for setup, or confirm that this is a problem

Sounds like a Cubasis drum issue then

Hi Mystic38,

Please check the sample mapping range from the drumkit wich is assigned inside your cubasis midi track.
You can see it inside the midi editor. Is the mapping range from your genome kit outside of the
mapping range from your cubasis drumkit, you can’t triggered it with genome.

Example :
Cubasis Drumkit mapped from C3-C4
Genome Drumkit mapped from C4 - C5
Result : Only C4 is audible because the key note C4 is assigned in Cubasis and Genome
Note : C#4-C5 is empty in Cubasis, no samples are mapped in this range.

best jan

Hi,
Thank you for your reply, but this is not a key mapping issue…

I am able to play the kicks correctly …so they are on the right note
I am able to play the high hats (or any other hit) correctly, so they are also on the correct notes

But Cubasis cannot play two hits in the same time slot… for any given time slot it will only play which note was placed last in that slot, and sometimes will not play two adjacent notes…

I add that if I replace a drum kit with (say) a piano and the results are same…

My OP was using both Apps on one ipad… and this issue is 100% reproducible every time.

Further tests from me indicate that…

  1. Genome works perfect with every other app, and also external gear.
  2. If, with both apps running on the one iPad air, i direct Genome output to StepPolyArp, and direct StepPolyArp output to Cubasis (and do not enable either sync or the arp in the StepPolyArp app), it effectively loops midi in to midi out, and taking THAT data, Cubasis will operate correctly (most of the time).
  3. If i run Genome on a different iPad, and connect the 2 via iConnectMidi4+ and CCK then the results are the same as with two apps on one iPad… cubasis does not follow the pattern in the same manner…cannot paly or record chords.
  4. In a similar way as to the loop through StepPolyArp on the one iPad, if I direct Genome from one iPad to an external piece of gear and use the Midi thru back into the iConnectMidi4 box and onwards to CUbasis, it seems to operates correctly

If there are any further tests that i can perform to help hone in on the issue i would be happy to do so…

Essentially, i intend to combine both iPad and hardware synths so having Genome operate with Cubasis is pretty critical to me as Genome is the only really solid pattern sequencer that also supports multi channel and automation.

Thanks Again, Ian

I think it’s a Genome bug. I used Nord Beat 2, free in the App Store, and can get simultaneous drum hits from the AM Pop Kit. But I can’t in Genome.

Off to try Genome against other drum apps. It used to work.

This is extremely weird
Nord beat plays simultaneous hits in Cubasis drum kits
Genome plays simultaneous hits in SamplTank drum kits
Genome does not play simultaneous hits in Cubasis drum kits

Thanks for checking this out…at least i know for sure now its not me… Thanks for the tip i downloaded nordbeat and yes that did seem to work with Cubasis

Genome however does plays correctly with everything else i own… be it an external hardware synth or drum machine, and on the iPad it plays 1. sampletank
2. Alchemy
3. Garageband
4. MusicStudio

…but Cubasis and Genome don’t play well together… so i hope the Cubasis folks will look into this.

I have received contact from the developer of Genome and he is aware of this problem, and states that there is an issue in the way that Cubasis handles midi messages…

Please contact this developer and find a solution… Cubasis is largely irrelevant to me without the ability to support to support pattern play & record…

thanks.

I have sent a note to the Genome engineer to exchange about the issue.

Thanks a bunch!>>

Cubasis 1.8.3 will be released in a few days and includes a fix for a hanging / missing notes issue with specific hardware controllers (CB-1892). There is a chance that this bugfix solves the Genome issue same way.

Please give it a try at your end once 1.8.3 has been released and let me have your feedback.

In case of interest here is a list of all fixes included in the update:
http://www.steinberg.net/forums/viewtopic.php?f=183&t=68658


Thanks

Lars

Fixed! In 1.8.3. Thank you Steinberg!

Hi surfer,

I’m glad to hear that.
Thanks for testing and your feedback!


Thanks

Lars