[SOLVED] Dorico Pro 3.1 re-install problem (Win10 64bit)

I recently upgraded from Dorico Pro 2.2.20 to Dorico Pro 3.1. Everything was fine and worked perfectly.

Earlier today I was testing some musicxml files for import and noticed that they opened in Dorico Pro 2.x not 3.1.
I checked and found that version 2.x was still installed, so I decided to uninstall it.
I also use an uninstall scanner, which cleans-up “leftovers” after a programme is uninstalled, which is where I think my problem started.
When I tried to launch Dorico Pro 3.1 afterwards nothing happened.
I thought, “no problem” I’ll re-install 3.1

This is where I am hitting a problem:

  • I use the Steinberg Download Assistant to download the complete application.
  • Once it is complete I press the “Open” button which opens the download folder.
  • I start “Dorico_3.1_Installer_win.exe” (the Steinberg installer process is visible in the process manager)
  • The installer starts, uncompresses the installation files, the “Please wait while the installation programme initializes…” dialogue box appears and simply vanishes off the screen.

I am on Win10 Pro, 64bit, latest version.
I haven’t changed any settings or added any hardware since my original install.
I have the latest eLicenser manager installed, and it shows the license for Dorico Pro 3 as active on my USB licenser.
Just in case I disabled my anti-virus programme.

Any help, suggestions, hints would be greatly appreciated,


Is there any chance that uninstalling version 2 also uninstalled the “extra” Visual Basic .dll that the original Dorico needed in order to install?

Just a thought (shot in the dark).

Hi Derrek,

Thanks for the suggestion it is appreciated - I have tried to re-install ver 2 but I get the same problem.
Do you know where the extra Visual Basic .dll should be found - or where it can be downloaded from?

I solved the installation problem by extracting the “Dorico_3.1_Installer_win.exe” file.
It created a sub-folder called “Dorico” containing among others a “Setup.exe” and “Dorico3.msi” files.
I launched “Dorico3.msi” which proceeded to do a full install.
Just to be certain, I re-ran the original “Dorico_3.1_Installer_win.exe” which proceeded all the way through the install too.

Now everything is working again :smiley:

My clean-up after install utility must have deleted some vital install component.
Lesson learnt…

Glad you got it solved.