SOLVED - Download Assistant update problems

I tried to start up the Download assistant today – an alter popped up saying “Updating Download Assistant.” After 30-40 seconds, an error alert popped up directing me to a page on the Steinberg website.

I followed the directions on the page, started up the download assistant – same problem.

I uninstalled/reinstalled the Download Assistant. Same problem.

Does anyone know what’s going on with the Download Assistant?

Thanks,
Doug

Hi,

Did you install the components separately, please? If you are on Windows, did you install them as Administrator (same as Steinberg Download Assistant), please?

I did install the components separately. It seemed to make no difference to the end result.

This was shortly after the Licence Manager updated itself – perhaps I should uninstall that and try reinstalling?

Hi,

This might help. Please, make suer you install it as Administrator, if you are on Windows.

I uninstalled everything except Cubase and reinstalled it. I am still seeing the same symptoms. As far as I know, this doesn’t really affect anything, so I can probably just ignore it for now. Does that seem reasonable or should I continue working past this glitch?

Also, I should say: I’m on a Mac running Catalina with all the latest updates.

I’ve figured this out. The Download Assistant was trying update the eLicenser Control Center. It wrote the install file (DMG) to a temporary location and then failed for some reason. I installed the new eLicenser Control Center from the DMG that had been written. After that the Download Assistant made no more attempts to update anything.

Odd, but not unheard of.

Same Problem here. Downloading and installing eLicenser, Lib-Manager and DL-Manager didn’t help.

I figured out what was happening by running the Download Assistant from the Mac terminal and looking at the output. I don’t know if this is possible on Windows, but if so, it’s really helpful.

I tried this and it didn’t work. When you say “the DMG that had been written,” are there two? I used the one that I downloaded/written to my HD. Can you provide more step-by-step details?

Thanks

@MarkJohnson: This solution only works on the Mac - if there’s a solution that works on Windows, I don’t know how it would work.

I opened up the Mac Terminal program and started the Download Assistant from there with this command (it should be all on one line):

/Applications/Steinberg\ Download\ Assistant/Steinberg\ Download\ Assistant.app/Contents/MacOS/Steinberg\ Download\ Assistant

When you start it that way, you’ll see that it writes some output to the Terminal. At the end of the startup, I got a message that was something like:

“Using /var/folders/zc/somethingelse/T/eLicenserControl.dmg”

So I navigated to whatever that directory was and then still in the Terminal copied the dmg to my Downloads directory:

cd /var/folders/zc/somethingelse/T
cp eLicenserControl.dmg ~/Downloads

And then using the Mac Finder, I opened the dmg and ran the install program from there.

Hopefully this all makes sense…

Yes, I’m a Mac user. I ran the script in Terminal and searched for “using” in the output but couldn’t find. I did find:

stream: 01/16 17:38:24 [ NOTICE ] Download complete: /var/folders/ht/4kxc30j563ncdl9vzy5_mb3w0000gn/T/a9a8ca0a-35e6-4ede-8f5a-2cbfa276c7b5/eLicenserControl.dmg.sda-download

and

Destination Path for Product ‘eLicenser Control installer’ is set to ‘/var/folders/ht/4kxc30j563ncdl9vzy5_mb3w0000gn/T/a9a8ca0a-35e6-4ede-8f5a-2cbfa276c7b5’

From terminal, I ran: CD/var/folders/ht/4kxc30j563ncdl9vzy5_mb3w0000gn/T/a9a8ca0a-35e6-4ede-8f5a-2cbfa276c7b5

I didn’t receive any errors but I couldn’t find the root of that string (var/folders) from Finder.

From “Macintosh HD’ in Finder I searched for dmg and only found the three dmgs that were downloaded via the message provided by the Download Assistant.

So I’m still lost. I can’t imagine what less technical Mac users are doing at this point. Hopefully Steinberg will provide a more traditional user-based fix.

Thanks,
Mark

Yeah, it’s not possible to do that. You need to get there via Terminal and copy the dmg from the /var/folders… location to somewhere where Finder can access it. I used ~/Downloads

Finder doesn’t find the things like /var or /tmp.