[SOLVED] !!! Generic Remote, seriously !!!

I spend hours and hours with Cubase 5 to setup several Generic Remotes to my needs! I installed Cubase 6 fresh and set it up again, using exported Generic Remote .xml’s

I for example had a Generic Remote set up as follows:

upper Dialog:

Control “Stop”; MIDI Note 8 on Ch#0 received
Control “Stop indicator”; MIDI Note 8 on Ch#0 is send

lower Dialog:

Control “Stop”; Command; Macro; Stop
Control “Stop indicator”; Transport; Device, stop

The effect in C5 and C6 is:
When I press the hardware led-button for “stop”, the cubase macro “stop” is triggered.
When Cubase’ transport is stopped, the button-led is lit.

Now, when I export this Generic Remote setup to an .xml, and import it again, the bindings for the MIDI send controls are lost!!!

The Bug is: When importing a Generic Remote .xml, ONLY the first assignement of a MIDI command (upper dialog) is loaded (lower dialog)! Another assignement for that same MIDI command (but with different send/receive settings) is NOT loaded anymore!

I lost hours of work of setting up Generic Remotes!!! The hell!!! This wasn’t in Cubase 5!!!

Sounds frustrating. I don’t have Cubase 6 so someone else may chime in to confirm a bug… but if it’s not a bug…

Is your device communicating 2 way?

The remote xmp system is sensitive to the order of objects, like tracks, etc. If they changed the order of commands that could mess up your remotes. It seems unlikely they would do that, but stranger things have happened.

I know they probably are, but it’s worth asking. Are all the macros the commands are calling present in the Cubase 6 key commands?

Have you tried importing that remote xml back into Cubase 5 just to eliminate the possibility that the something is wrong in the export?

If you export the remote xml from Cubase 6, and import it into Cubase 5 does it work?

If you can, compare the exported xml file from C5 to a that same file after importing it and then and exporting from C6. If you post the device you are using, or attach the xml files that might be helpful.

The remote xml files are relatively simple, I edit them in a text editor to speed up creating them, and have screwed them up too. But as long as the xml formatting is correct they work. Unless there is some new bug (or one I haven’t seen).

good luck,


The receiving and sending Controller names must differ!

I guess this was my fault then, sorry!