[SOLVED] Hanging midi notes with external controller

Thanks for the info update!
Glad you could reproduce the issue to be able to find a solution.

I just bought Cubasis, excited at first in how it will change my songwriting workflow, but disappointed in the stuck notes with the included ‘Micro’ instruments. I use a 3rd gen Ipad with an Alesis IODock (1.07 firmware with its own stuck midi fix!) as the Midi Interface for my Yamaha NP-31 keyboard (all on AC power). I’ve also experienced the loss of notes when playing a single instrument/track, and hung midi notes with and without the sustain pedal. Microsonic PolySynth is the worst offender at both dropping and hanging notes.

I look forward to hearing if there is something to correct the problem or if we can expect the patch. Glad you’ve been able to reproduce the issue!

I just tried again after getting the latest update. I thought everything was working when playing but as soon as I tried to record the built in piano I started losing notes. My workaround is to record SampleTank using IAA. It’s odd but I just recorded a full song that way with no problems,

The issue is in evaluation.

has this evaluation progressed?

Thanks for your help

Hi Aatu,

Good news: we’ve been able to reproduce the Alesis Q49 issue.
A fix is planned to be included in the next Cubasis update.



Hi Jan & RG,
I am having the same experience as Paul, using iOS 8.1 and Alesis Q49.
I hope you will be able to post an update to Fix this soon, as it is unusable to me now.

Thank you for a great app. But it is now broken with the 1.8.1 upgrade (ipad Air, 128GB, 8.1 Operating System, Alesis Q49 controller and Lightning USB connector).

I can completely concur and confirm that what has been said here in this string about hanging notes and loss of polyphony is happening to me as well. In fact, I cannot reliably play more than 1 note at a time from my Alesis Q49 midi controller without losing notes. I am using an authentic Apple brand Lightning to USB adapter. That same controller and interface works fine with all of my other music apps. So I know it’s not the controller or USB connector and it is not likely the iPad that is the issue. The problem exists even with a brand new project with only 1 instrument loaded and no tracks playing, all other music and instrument apps closed, just Cubasis running.


As mentioned above, the issue will be fixed with the next Cubasis update.

Now that 1.8.3 has been released please let us have your feedback about the interaction between Cubasis and your external controllers (that have not worked before).



First test with my Micrikorg XL+ (through camera connection kit / usb) went absolutely smooth. No hangers any more, no matter how fast I played.

And the folder structure (constand open folders up to 1.8.2) does not drive me crazy any more.

Really happy with the update so far!

We are more than happy to hear that! :smiley:

Same positive result with Kingkorg synth (midi over usb).

Thanks again, jimknopf!

Thank you for good work, this update solved all my problems with Cubasis and Alesis Q49.
Now everything works fine.



very glad to hear!! :sunglasses: