[SOLVED] Hanging midi notes with external controller

It is probably better to clarify that in a separate thread:

Every some seconds I get hanging midi notes, whenever I play or record in Cubasis 1.8.1. with an external controller.
This happens about once in two seconds: it is practically impossible to record more than small snippets while readjusting the hanging notes all the time.

The hanging notes appear regardless of midi track configuration, even in the most simple setups with just one simple internal Cubasis instrument.

As this makes playing and recording in Cubasis practically impossible for me, I am very interested in any solution.


Sorry to bother the Steinberg team with issues so soon again, but I think, besides my own wish to record with Cubasis, it is in common interest to get such problems solved.

I completely deleted and reinstalled Cubasis 1.8.1 meanwhile after backing up my projects, just to be sure that none of my settings was influencing the midi problems.

It stays as bad as it was: I do not only get hanging midi notes with my external controller keyboard.
Cubasis also loses notes: if I enter a chord repeatedly it just misses a chord note in many of the chords, as midi recording proves. I get the same problem with two different midi controllers, and both have been working without any problems with PC and Notebook drivers in Windows7.

And on the iPad is a Cubasis problem exclusively: I have none of these problems playing Sample Tank or other apps with the external keyboard (no hanging notes, no missing notes).

This looks messy to the extreme and completely unuseable. I can’t do more at the moment to clarify matters.
Please someone from Steinberg give a short feedback.
It would be helpful to know that someone is aware of the problem and perhaps working on it.

HI,

I will investigate for your on this matter, but unfortunately you will have to wait till after the weekend. Sorry for the inconvenience.

Greetings
RG

Thanks for the reply, and have a nice weekend!

My enthusiasm for lightweight recording with Cubasis outweighs the frustration about the obstacles so far :wink:

Hi Jimknopf,

It’s definitly not reproducible here, I am use everytime an external keyboard. ( Midimate II & motif ES8)
Maybe it’s your midi interface wich is different between iPAD and desktop computer ?

If you have hanging notes with cubasis instruments, use the midi panic button “(!)” near the “CPU” metering.

For missing notes, check your polyphonie settings and set up to 128.

We need an detailed step by step description for the repro, or send us the project.

Wich external midi interface and keyboard you are using ?

best
jan

Meanwhile I’m back home and able to check again.

The problem stays with my Kingkorg Synth (I tried another one in a store to be sure mine was not faulty). It has a class compliant USB connection. The funny thing with this synth is that I can play and record without any problems in Sampletank, or play other iPad synths, but get hanging notes and dropouts in Cubasis. No idea yet what may cause that.

The problem does NOT occur with my Microkorg XL+ in Cubasis. This is good news to me, since I often use the small, battery powered Microkorg for mobile purposes on the fly (idea sketching etc.). I will check the connection with my Korg Kronos tomorrow just out of curiosity. Later this week I will get a Focusrite iTrack Dock and check playing midi and audio through that interface as well.

So you are probably right that it could be a problem related to a certain keyboard, in this case the Kingkorg (a nice light 61-keyboard well useable on vacation). It’s a pity I haven’t found any setting changes on either side eliminating the problem.

I also am experiencing stuck midi notes. This is only with an external midi controller and only on internal Cubasis instruments. This was on 2 different midi controllers. I go from USB to Apple camera adapter to lightning port on iPad Air.

HI Stringy_D,

can you please provide us with as much info as possible? A step by step description, what exact gear are you using?

Thank you!
RG

For all keyboards tried: use a USB cable into the official iOS camera adapter for a USB to lightning connection. Open Cubasis, arm a track for midi, use either micrologue or micro sonic. Novation Launchkey 61 = stuck midi notes. An old Evolution MK49c = stuck midi notes. However M Audio keystation 49 (2014 Model), I do not have this problem.

Hi stringy_D,

Did you use the Novation Launchkey 61 and the Evolution MK49c without an external power supply ?

Please send us an detailed midi / ipad setup configuration.

I can’t confirm stuck midi notes here.

best jan

Jan, have you checked the issue with different keyboard controllers and synths or only with one or two?

I meanwhile have tried different ones on the fly with varying results, just like stringy-D experienced: there is definitely something not working as expected with more than just one or two external midi controllers in Cubasis. It’s not easy to find the reason, though, or even find hints to what might cause the issue. If it were just one or two keyboards not working well, you could just take others and ignore the problem, but it occurs in too many combinations with Cubsasis.

Even the solution I found for recording with my Focusrite iTrack Dock (Focusrite USB -> USB-to-midi ->Microkorg midi) does not work 100%, as I originally had thought (see other thread). After some playing it became clear that the note drops are just quite rare in comaprison to other more problematic controller/Cubasis combinations, but they are not completely gone.

It would be great if you guys at Steinberg could test various controller combinations to get your own impression of the problem. Playing (and recording: there it becomes visible) relatively fast arpeggios for a while works best to notice missing notes, and fast runs are best for detecting hanging notes, as soon as you check controller/Cubasis combinations in question. With some controllers I also got hanging notes (for example Kingkorg), with others just missing notes to a bigger or smaller degree.

Hi Jimknopf,

It would be great if you guys at Steinberg could test various controller combinations to get your own impression of the problem.

We did it and we can’t reproduce stuck notes, hanging notes etc.
Works here with Midimatte II, UR 44, iRIG1, iRIG2, Yamaha i-MX1, Motif ES8, Motif xs 6, M Audio Axlom49 etc…

It’s not only the controllers, you need also an external midi interface, so we need a detailed midi configuration description to repro your setup, with external controller power supply or not etc .


best
jan

Hi Jan,

from your list above and the feedback form stringy_D and me above, a first educated guess seems to indicate, that generally

  • Yamaha and M-Audio Axiom seem to work fine in your tests
  • with several Korg keyboards, a Novation Launchkey and an Evolution 49 there have been issues
    It would be helpful, if Steinberg has access to them, if you could check some of the devices with critical feedback to narrow down the issues.

I only have 4 controllers in my home studios (3 Korgs and a Moog LP) and have tried others on the fly. For those I have I will give you a more detailed setting in one of the next posts.

Hi Jimknopf,

http://focusrite.de/ipad-audio-interfaces/itrack-dock#tech-spec

They wrote in iTrack Dock spec list :

Known incompatible controller with iTrack Dock " Korg microkey37, Korg MS20ic ".

I think the cause of stuck notes, hanging notes is the combine between midi interface and controllers.
So we need detail information about midi setup, etc…

best
jan

Ok, so here’s my first thorough test description with my Kingkorg VA synth.
I begin with camera connection kit setups without additional hardware interface (Focusrite or others).

First I have to mention, I found out that the comparably best results happen with Apples original connection kit, not with two others I have from other manufacturers (despite being “compatible” and working well with photo import). The compatible devices generally add their own to the described problems. So I only use the original apple adapter to avoid any issues of that kind.

Actual testing configuration:

  • Kingkorg (works only powered) Midi out (channel 1) over class compliant USB midi out via USB cable
  • USB through original Apple USB camera connection kit (lightning adapter) into iPad Air
    Result:
  • no midi hangers or dropouts playing in IK Multimedia Sample Tank, Arturia iMini, Korg iMS20, Waldorf Nave etc.
  • midi dropouts within Cubase using the internal Piano (or other instruments) from Micro-Sonic
  • Cubasis midi input connection routing is set to Kingkorg keyboard/controller

The funny thing is that the Kingkorg works without problems as midi controller with other apps in the setting I tried - only in Cubasis I get casual (not constant) note dropouts.

Any more questions concerning this setup?

Hi jimknopf,

Thanks for the Infos !

no midi hangers or dropouts playing in IK Multimedia Sample Tank, Arturia iMini, Korg iMS20, Waldorf Nave etc.

  1. Are you closed these APPs before you running cubasis with kinkkorg as midi input and using microsonic ?
  2. What say your setup settings in " Polyphony, Hardware latency, large recording buffer, Sample rate "?
  3. Are your drop outs during the playback and playing on kinkkorg?
  4. Are your drop outs in stop mode and playing on kinkord?
  5. How many iAA and Micrologue instances are loading in your project?

You know if your project reached the polyphony voices, CPU overloading etc, you get drop outs, lose voices etc.
Polyphony set to 128 means that you can only play 128 voices as midi note and audio files simultanoesly.
Sustain added the voices how long you hold the pedal.

1 audio file = 1 voice
1 midi note = 1 voice

together = 2 voices

Please check in these steps :

  1. close all apps and restart iPAD Air
  2. launch cubasis, create new project and create one midi track
  3. assign to micrologue or microsonic instrument and assign some preset
  4. Play on kinkorg as many notes as you can play

What is your result ?

best
jan

Checked your questions meanwhile, and here’s the result.
My test setup was exactly as described in your steps 1-4 at the end of your post.

  1. All other instrument apps closed, just cubasis running
  2. Settings:
  • polyphony: 32, no change of behavior at 64
  • hardware latency 256 (iPad Air 128 Gb)
  • large recording buffer off
  • sample rate 44.1 khz
  • no sustain pedal connected
    3.+4. Midi dropouts in Microsonic intruments happen both while playing, and while recording from the Kingkorg
    Then the missing notes (for example in chords) are visible in the recorded track as well and therefore played back like in live play.
  1. In my test setup I have only one instance of Mcirologue and no other intsruments running, just to be sure.

The result is still missing notes and casual (rare) hanging notes.

And the difference is still, that none of the problems occurs when I use the same keyboard (Kingkorg) with the same original Apple cam kit and other synth apps: I get these midi problems with none of the other I tested so far.

Something within Cubasis midi implementation seems to work different than in the other apps, and it obviously causes midi problems which do not occur with the other midi intrument apps.

Focusrite has similar problems: with not so few midi controllers their interface just does not work properly, even though they are class compliant, and even though the same controllers work just fine with the Apple camera connection kit.

Seems like homework to do for both companies, to get at least on the compatibility level of the camera connection kit for class compliant usb midi connections.

Hi Jan & RG,

Thank you for a great app. But it is now broken with the 1.8.1 upgrade (ipad Air, 128GB, 7.04 Operating System, Alesis Q49 controller and Lightning USB connector) and it was running absolutely perfectly just prior to this upgrade.

I can completely concur and confirm that what has been said here in this string about hanging notes and loss of polyphony is happening to me as well. In fact, I cannot reliably play more than 1 note at a time from my Alesis Q49 midi controller without losing notes. I am using an authentic Apple brand Lightning to USB adapter, (usually sold for camera connection, but is well known to work great for midi as well). That same controller and interface works fine with all of my other music apps. So I know it’s not the controller or USB connector and it is not likely the iPad that is the issue. The problem exists even with a brand new project with only 1 instrument loaded and no tracks playing, all other music and instrument apps closed, just Cubasis running.

I have tried changing all midi and polyphony settings in Cubasis, rebooting, etc. The v 1.8.1 update has essentially reduced Cubasis to being just a monophonic set-up (that refuses to play even 2-note chords) and that hangs notes quite frequently. Sadly it is unusable.

I understand that you can’t reproduce the problem on your end. Please be assured that there is a problem, a big problem. The last bug that I reported, you were thankfully able to reproduce, and you promptly fixed it in the next upgrade. Thank you. Please do so again.

Thanks,

Paul

Hi,
i´m a rookie here, thanks for this interesting and useful forum and all posts in it.

i have the exact same problem with apple cck + ipad air + Alesis Q49 + Cubasis or Nanoloque (no other instruments apps running). It really does the same with only Nanoloque running.

I tried this with my wife´s electricpiano (Thomann DP-30, it´s midimodule is made by Medeli) and everything works with it.

I would really appreciate to get help with this problem.

Thanks.
Aatu

Hello,

thanks to your contribution we could reproduce the problem of the hanging notes in our labs!
This problem occurs when working with certain MIDI devices that use USB connection. We will continue our investigations on this rare problem to find a solution and will keep you updated!