[SOLVED] help for recording midi-in, from in-device sources?

Meaning I want to use an IAA app to record a midi track into Cubasis. I’ve tried Modstep, and Tera synth, both of which have midi send capability, and it seems Cubasis is set up to record midi tracks from data coming in via IAA, but what I get is a blank recorded track, or if I’ve set up 4 ins from Modstep only one blank recorded track out of 4 (this in spite of arming all 4 tracks to record, and de-selecting both “Midi input only for selected track” and arm selected track…the single track recording out of 4 armed seems like a bug, the lack of any midi-in recorded at all seems like user error on my part, Cubasis is spozed to do this no?

Hi Littlewood,

Please have a look at the IAA tutorial we’ve released when introducing IAA with Cubasis:

https://www.youtube.com/watch?v=sDfZvwPrkTo

Please let me know if it helps to solve the problem.

Best,
Lars

Thanks Lars for the quick reply, and thanks for the video. And thanks to you and your team for an incredible application!
Unfortunately the video doesn’t cover my question. It seems that Cubasis is set up to record midi note information in, and I’ve noted from other threads elsewhere on this forum that Cubasis is able to record midi note info from external midi controllers: midi note info can be recorded onto a midi track from an external hardware keyboard for example.

It seems that Cubasis is designed to do this also using an indevice source of note data also, say an IAA instrument, used as a midi-in source, should be able to send midi note data into a Cubasis midi track, for example from the keyboard of a synth app that has send-midi functionality (Tera synth, in my tests) or a sequencer app that sends midi from its piano roll sequencers (Modstep is one)

Maybe I’ve misunderstood the use of the selection of “midi in” in the router section of the track inspector, or maybe I’m not setting up the feature of “midi in” correctly?

Hi Lars, after my reply re the video link, (see above) I’ve tested a bit more. I was able to use an app external to Cubasis, (Cyclops) to record midi note data into a Cubasis midi track, using that apps keyboard. so far I’ve tried Nanologue, Tera, Modstep, and only Cyclop worked. It seems that Cubasis is able to record midi data into its own midi tracks, using another app with midi send…not sure if the other attempts I made failed due to a bug or my own error in setup. The difference in Cyclop seems to be that it is able to select Cubasis directly as a destination. Modstep also has multiple ways to select Cubasis as a midi destination, but…

Either way, Cubasis is the best.

After many trials, this appears to be an issue of the many IAA synths own implementation of midi send, on a case by case basis…