SOLVED! Help! Tempo Sync problem with Korg Minilogue XD

today I’m trying to sync the Monologue Arpeggiator with Cubas tempo.
Cubase 11 on mac here.

On Korg ML settings I set Clock Source on USB
In Cubase, under the Destination Midi Clock settings I check the Korg Monologue midi usb Port as MIDI clock destination.

The problem is that when I start Cubase and play keyboard, the sound become crazy with a 128note for second and I need to stop playback.
As test, for know if it is a Korg problem, I’ve tried to do the same operation in Logic and all works fine. At this point I know that the issue is in Cubase but I don’t know how to solve.
If I leave unchecked the Korg port in Cubase midi sync settings the problem does not appears but at the same time I’m not able to sync the instrument with the Cubase project.

In Cubase, in midi input ports, if I select another external midi keyboard, instead of ALL MIDI input, all works fine and the Korg read the midi clock correctly.
BUT if in the midi input devices list on the track I select the Korg ML or All midi inputs, then the issue return. I suspect that Korg Monologue keyboard and Cubase have a sort of midi loopback that I don’t understand why is only in Cubase and not in Logic.

Solved by disabling Thru midi Sys Ex in the MIDI-Filter preferences in Cubase.
Maybe Korg Monologue XD send sys exlusive messages from the physical keyboard that generate a midi loopback that corrupt midi arpeggio notes.