[Solved] Instrument change labels - bug?

After I’ve edited an instruments name the Instrument change labels for that instrument doesn’t follow the settings in Paragraph Styles -> Instrument Change Labels. Is this a bug or something I’m doing wrong?

In the pic below I have edited the Flugelhorn in the 2nd trumpet to Flugelhorn - Changed





InstrCangeLabels.PNG

Does it show the same way if you switch into Write mode? There’s a known (since Dorico 1.0) limitation where you need to switch away from Setup mode for Setup’s Preview image to refresh.

It looks the same in all modes and in the parts.

Possibly you’ve changed the formatting explicitly in the short name for Flugelhorn 2? Dorico will try to maintain any existing formatting you provide, though it will always use the ‘Instrument change labels’ paragraph style rather than any other style you choose in the Edit Names dialog. The attached trivial example shows that in general this works as intended.
inst-change.dorico.zip (140 KB)

Daniel,
It looks fine in your file, but when I add an instrument to one of the players and edit the instrument name I get the same result as in my original post.
The only thing I’ve done is editing the name, nothing else. (See the attached file)

I got prompted that your file was created in an earlier version of Dorico, have you tried in the latest build?
inst-change_2.zip (1000 KB)

Daniel,
Here’s a short (and shaky…) clip showing what happens. I don’t understand what I’m doing wrong? to me itt looks like there is something spooky going on…

https://1drv.ms/v/s!AriKcCSmpi4gjfFwzVBEFfHl1cj6gg

You have to select the Instrument Change Label style from the dropdown menu in Edit Names.
I don’t know why, but I do know it works.

edit: Daniel said this above.

Changing to the Instrumeng change label-style also changes the staff labels in the score. In Daniels example above there are no such changes. I still wonder what Daniel and his magic touch has done to make this work…? :confused:

Well, Daniel, I opened your project (with the same warning from Dorico that it had been created in a newer version), added another instrument to the second player, renamed it Coconut/Coco (Full/short), made sure that the paragraph style was correct (Staff label) and it shows Regular in the score as a changing instrument label, instead of italics (as your “To Ban.”)

It’s the exact same settings in the name editor as for Banana/Ban. instrument! Why this inconsistency?

Even more strange: If you change Custom text in the Properties, in Engrave mode, it returns to the right formatting.

I’m at a loss; I’ve done exactly what Mats shows in his shakycam footage and the formatting stays correct for me. Can you create a trivial new project like the one I attached in my initial reply to this thread and reproduce the problem in there? If so, please then attach it here so I can take a look.

Daniel,
I’m sorry for the delay, I had to log out and keep up to my deadlines and found your reply now.

I posted a reply to your earlier post where I had added a custom instrument name the attached file. Here is another one.

When I opened your file I was prompted that it was created in a newer version of Dorico than mine. But I guess you’re using Mac and the Mojave-update.

So, here is a file in which I’ve changed the name on the trumpet.

We had a discussion on the Facebook page too and it seems that I’m not the only one having the same issue.


CustomInstrumentNames.dorico.zip (307 KB)

YES!!! With 2.2 this issue is gone! Thanks!