SOLVED. Limiter and Brickwall Limiter is "stuck" or (kind of) deactivated


I just insert a Limiter on my kick drum instrument track. When I did so, it just deactivated itself right away, and I cannot open the editor, press the bypass button and not even replace the plugin! It just deactivates completely somehow. Just to see I inserted the Brickwall Limiter below it, and the same happened with that one as well. It doesn’t happen for any other plugins, and it happens on every track I try to insert them on, both instrument tracks and audio tracks.

I run the 9.5 Pro in demo mode but that shouldn’t have anything to say? (I run the 9.5 demo because Steinberg haven’t replied to my support ticket in almost a month now about a license issue, are they completely overrun by support request or something? I only have 4 days left of the demo so it’s getting urgent! :open_mouth: ) In the plug-in manager it says both plugins are active…

Does anyone know what the problem may be and how to fix it? This is how it looks and like I said all three buttons are completely dead and transparent in the appearance, not gray like in bypass mode.

Solution: I just realised I was in Constrain Delay Compensation mode, sorry folks!

Thank you! I ran into the same issue!