[Solved]Mac Trackpad Multitouch Issues

I just picked up SpectraLayers Pro 7 trial. I want to love this software, but I’m having a maddening time trying to control it via trackpad. v7.0.30, 2019 16" MacBook Pro running 10.15.7.

  1. When I use two fingers to pinch-to-zoom or scroll, the software sometimes responds as expected. Other times, nothing happens. Other times, it does some combination of a partial zoom and a click-and-drag.

I can recreate this every time by opening a new project and pinching in and out repeatedly. The gesture will sometimes work, sometimes do nothing, and sometimes trigger click-and-drags.

The click-and-drag issue seems to stem from the fact that when I touch-and-release the trackpad with two fingers (not physically click the trackpad, just touch), SL interprets this a click. I do not have “Tap to click” enabled in the OS settings, so software should not be interpreting any touches – let alone two-fingered touches – as clicks unless the trackpad is physically pressed. I would guess this bug is related to your Wacom support.

  1. When I try to use two fingers in a scrolling motion, I get a very slow scroll with constant in/out zoom jitter (and, naturally, more of those sporadic click-and-drags).

Maybe this issue is simply that the zoom sensitivity is too high relative to the scroll sensitivity? Pinch-to-zoom on a non-touchscreen interface is simply not an intuitive input mechanic to begin with, so if the implementation isn’t perfect then it shouldn’t be there at all. But as it stands now, even if zooming was disabled, multitouch scrolling is just way too slow.

The overall experience of SL on a trackpad is very unpleasant. I know re-writing a multitouch input engine is a pain, but the implementation you’ve got right now is just an instant turnoff.

If you don’t want to write a proper platform-dependent input engine, please just do a band-aid fix by exposing these settings:

  • Enable/disable two-fingered tap registering as a click
  • Independent sensitivity adjustment of pinch-to-zoom and two-fingered scrolling
  • Independent enable/disable of pinch-to-zoom and two-fingered scrolling

If you can please address this, it’ll be a guaranteed purchase for me and I suspect you’ll see a much higher conversion rate overall.

Thank you for your help!

I ventured back to SL 5 and the multitouch issues were present even back then.

Even knowing the root cause, I still can’t keep myself from inadvertently contacting the trackpad and sending SL haywire with random zooms and clicks. It’s impossible not to rest your left palm or your right thumb on the trackpad since it’s so large. Apple trackpads are intended to be used this way. All other modern software accounts for this by either using Apple’s APIs or by spinning their own multitouch handling solution to reject incidental contact.

Is there anyone out there who manages to comfortably use SL on an Apple laptop?

Can confirm this is fixed in SL 8! Everyone should note that multitouch on the trackpad now respects the settings selected under Prefs → Shortcuts - > Mouse: Wheel. This is excellent, but it also means you need to make sure to uncheck the “Invert wheel axes” setting, which is enabled by default. Otherwise your horizontal finger movement will cause vertical scrolling in SL.

Thank you, Robin!

1 Like