[SOLVED] Mackie Control MCU doesn't show plug-ins parameter pages, only EQ


So, basically, the same problem as described in the NI forums. Not sure if the problem is the Cubase Mackie MCU implementation or something else?

I’m using a Maschine hardware to connect to Cubase Pro 10.5 built-in Mackie Control facilities.

Now, data feedback on the Machine display clearly shows that there are pages for plugins loaded: PAGE: 01/08. But, I can’t access them through the Maschine MCU Mackie Control template.

Can someone confirm Mackie MCU is working through a generic midi controller in Cubase Pro 10.5? Maybe some internal limitations are preventing Mackie MCU to show full data?

I hope someone can give me hit & help.

Thanks in advance!



On the Mackie Control Universal hardware, there are Channel L/R buttons. As described in the manual:

To move to the next or previous Page within a parameter group, press the right or left CHANNEL button in the FADER BANKS section.

Does Machine provide these Channel L/R buttons

Yes, it does, but no matter what I do, I can’t reach the (sub) pages with plugin parameters listed. Only Cubase Pro stock strip EQ.

Not sure what to do.


Are you sure you are on the plug-ins page? If I’m right from top of my head, there is a dedicated page/view for the EQ.

…Which is shown when I press ‘Plug Ins’ as on the attached screen dump. No matter what, I just can’t get access to the loaded plugins or VSTi pages. Is that a Cbase ‘normal’ behavior in a generic MCU mode?

It turned out that the Parameter ID for channel L&R navigation was wrong. They need to be 48 and 49 - NOT 40 and 41.

Maybe the template wasn’t updated with MCU’s latest changes.

Case closed.

The problem is that I can’t access or see the parameters for VST instruments. There’s no problem with slot-loaded effects, but when I turn VPOT 1 to USER - there’s no trace of VSTi instrument.

Maybe they have changed the MCU Parameter ID logic for that in the latest MCU update, too?

Any help will be appreciated. Thanks.

You have to click it down to access the plugin. On an actual MCU, you would press down the rotary knob. On the Maschine, the rotary knobs can’t be pressed down. They do nothing. That is why you can’t select the plugin. Because there is no select button. Since the rotary knob can’t be clicked down, there is no way to select the plugin.


They definitely didn’t change the specification for 20 (maybe even more) years in Mackie. Mackie Control Protocol hasn’t changes for years.

VSTi is not taken as a plug-in in this case. Only Insert effects are taken as a plug-ins.

So, what parameters exactly do you want to reach, please? VSTi? Like all VSTi parameters? The same parameters, you would see, if you switch to the Generic view in the VSTi in Cubase?

Actually, you can :slight_smile: I’ve tried and it works. But some Mackie template Parameter ID values in the Machine (or other generic controllers) need to be changed first. Here is the solution:

  • Assign a button to MCU Parameter ID 80. It will state ‘FDR Group’. That is translated as an ‘Instrument’ (…). Push the button.

  • Then, if they are not already assigned, assign buttons to MCU Parameter ID 48 (CH LEFT) and MCU Parameter ID 49 (CH RIGHT). Push them to navigate VSTi parameter pages :slight_smile:


It is, but it needs to be accessed through the MCU Parameter ID 80 - ‘FDR Group’. See my answer above.

Nice one. I have a Maschine Studio but I have never tried to use it to control plugins as I have a separate control surface for that. The Maschine is right in front of me all the time so it might be more practical in certain situations so I will give your tips a go. Which buttons did you assign them to? You just did it in the Maschine Controller Editor?

Good idea!

You can choose to assign them to buttons of your choice. In my case:

Pad Groups A (Select VPot-assign) Page:

Pad 9: MCU Button Parameter ID 48 - < Chn
Pad 10: MCU Button Parameter ID 49 - Chn >


Pad Groups C (Solo/VPot-assign) Page:

Pad 9: MCU Button Parameter ID 80 - FDR Group

Have fun.