[SOLVED] midi keyboard shows activity but Vst doesn't play!

Hi,

Since a week a very weird behavior on C7.5: midi keyboard plays fine on standalone Vst but once I open Cubase and add a midi channel and try to play with any synth, then even if there’s activity thru ( I can see it on the Transport Panel) there’s nothing that plays!! That’s kind of a problem here. Also the Piano Roll on any midi part doesn’t plays anymore… I tried many things in the Preferences and the Devices setup but nothing!

Please help! Should I re-install Cubase then? Something was lost in the Registry maybe?

Thanks!

Aloha Z,

I sometimes get this when using HalionSonic 2.

( keep in ming I am on a Mac here so might not be the same prob).

What I do to fix this is remove the loaded sound.

Here is the trick. (for me anyway)
I don’t just ‘unload’ the loaded sound but I actually have to use the ‘remove’ feature. (the lil trash can)

Everytime I do this I hear a lil ‘bump’ as the VST is being removed.
Then I reload the sound and all is fine.

Hope this works for you as well.

BTW
this only seems to happen with HS2.
All my other Steiny and 3rd party VSTi’s do not seem to exhibit this behavior.

Good Luck!
{’-’}

Many thanks but I’m on PC and this behavior happens to any loaded Vsti, unfortunately your trick won’t work.
I already tried everything I could beside removing, loading a new Vsti, etc etc… that’s why I’m here
Thanks again!

Is Cubase playing audio ok?

Do you have the correct interface driver selected

Do you hear the vsti if you play it’s built in keyboard?

Do you have the correct stereo output assigned in vst connections?

Many thanks!

Amongst the excellent troubleshooting questions that Grim posted, there’s one more :wink:
Even though you don’t hear anything while playing, can you record onto a MIDI/Instrument track, and do you hear it play back o.k. after recording ? (If that is the case, seems you have simply disabled MIDI Thru :wink: )

Thanks for this ! Your question gave me the idea to reset the ‘Preferences’ even tho I had one setup saved the way I like. I then have had the recording from my Midi keyboard working. I have then went back again to the Prefs. and checked Midi Thru ( I have to say that it was checked before, when the problem was already there )…and Bam! Its all working again :sunglasses:
So I believe there was a problem in the Prefs. I have made and saved in the past, but I have no clue which one or why because the Midi Thru was always checked all the time. anyway…