[SOLVED] MIDI Prob using Audio Interface at same time w/Hub

SOMEONE PLEASE HELP ME!!!. Can’t use an Audio interface and MIDI controller at the same time using a powered hub into my iPad Air 2 (using the Apple USB3 or USB2 Camera Adapter kit). Please read and help me if you can:

I am going nuts. I have two different audio interfaces and four different MIDI controllers and two separate powered hubs and no matter what configuration I try, I cannot get one Audio interface and one MIDI controller to work at the same time through a powered hub into my iPad, using an Apple Camera Kit Interface. No matter which audio interface (I have the Steinberg UR 44 and the Zoom U-24)and MIDI controller (I have the M-Audio Axiom Air 32, the Maudio Oxygen 25, and the M-Audio Axiom Air 61 and the Samson Graphite 49 USB keyboard) combination I try, I get the same problem. Each individual device works fine directly into my Lightning USB3 Camera Kit to the iPad Air 2 or through an Anker or Tripp-Lite powered hub alone. I can even plug two MIDI devices into the either USB hub and then into the Lightning USB3 Camera Kit to the iPad and both MIDI devices work.

HOWEVER, as soon as I plug any one MIDI controller in the hub and any ONE Audio interface into the hub at the same time, the MIDI controller cuts out and only the Audio Interface works. This seems to happen with Cubasis as well as other music programs on my iPad Air 2, such as GarageBand. However, when I look up what other people do, I find no one else seems to have a problem plugging an audio interface AND a MIDI controller at the same time into a hub and then into the Camera adapter to the Ipad. For everyone else I can find on the Internet, this configuration seems to work. The only variable is that many mention that they are using a Belkin hub. I am buying a Belkin hub to try that out, but I don’t see why that would make a difference over an Anker or Tripp-Lite hub.

Does anyone have any suggestions? Has anyone come across a similar problem.

PLEEEEZZZEEE I NEED HELP!!! I’M GETTING SO FRUSTRATED AND I HAVE NO IDEA WHO TO CALL SINCE THERE ARE SO MANY DIFFERENT BRANDS OF DEVICES INVOLVED

I can’t say for sure - just guessing here. …
Both the audio interfaces you have also have midi ports. I’ve read iOS can be picky about having only one interface at a time and the audio interfaces are probably grabbing up the midi ports.

Perhaps the order they are connected to the CCK might help; (first close all apps and reboot) , then connect an audio interface to the hub, then connect a USB controller. Maybe the most recent will grab the midi ports.

Do any of your controllers have 5pin din? With just an interface connected try using the midi inputs on it…

FYI, you might try over at the audiobus forum - the topics and users there are very diverse and have plugged up thief stuff all sorts of ways…

Hi marsxmarsx,

Maybe an USB Host to Midi Converter like " Kenton Midi USB Host " solve your issue.

Connect the

  • M-Audio Axiom Air 32
  • Maudio Oxygen 25
  • M-Audio Axiom Air 61
  • Samson Graphite 49

to your USB Hub with external electrical power supply and go from the USB Hub into the

  • “Kenton Midi USB Host” with external electrical power supply

and from the " Kenton USB Host to Midi" Converter > Midi output into the

  • UR 44 Midi input

and from the UR 44 via USB to the iPAD

Don’t forget to accommodate all devices with external electrical power supply.

I can’t give you an warranty that it’s works as you expected, that is only an idea from me to solve your issue.
We had no experience with the “Kenton Midi USB Host” converter.

Please let us all know if you solved it in this way.

But the easiest way is to connect the Samson Graphite 49 or the M-Audio Axiom Air 61 directly to the UR 44 Midi in.
I know it’s not possible simultaneously without an Midi Interface, but better than nothing.

best Jan

Just to add a bit of solidarity … Ive just experienced midi timing problems (seems to go in and out of sync) and very weird echoing of audio while using my behringer uca222 and a m-audio midiman me 2x2 midi controller both plugged into a powered hub. Very frustrating. Ive been using this setup for a coupe of years, admittedly it has had a variety of problems in the past but the usb devices never seemed to clash like this before. I havent tested this setup with another daw yet but my suspicion is this is a cubasis issue.

My setup. Cubasis sends midi clock to midiman midi. Uca222 receives audio from rs7000. Which then appears as an input in Cubasis. The timing goes out quickly and then if I stop and start the clock by clicking play in cubasis a few time then I get a echo of the audio being sent from the rs7000. I thought this was just a stuck note but midi panic and switching off the rs7000 didnt kill the sound, but closing cubasis did stop the audio loop. Ive seen a lot of unwanted artifacts, cracks and hisses on the ipad but this is a new one on me. Ill continue to investigate.

Ok, a bit of further investigation. Oh, I just wanted to say that Im also using a Anker hub, a 7 port usb3 powered one.
This isnt only cubasis for me. The same thing happens in Auria Pro. (It really kills auria too with the same audio looping of audio in channel)
In my tests Im syncing external midi through the m-audio midiman while recieving and sending audio through the uca222.
Ive tried with the old and new cck and with and without a powered hub (using power from the new cck)
All my results have awful midi timing that drifts in and out and after pressing start and stop a few times or about 3 minutes after generating sound some weird loop of the recieved audio from the uca222 is generated until I reset the host app.
I think this is a problem that needs to ported to Apple. Can anyone let me know how I do that?

Hi,

It should be possible to file a bug report to Apple’s Bug Reporter system.
Please browse the web to find more info about the procedure.

Best,
Lars

I can only find a way for developers to log errors/ bugs.

Ive been further troubleshooting and this isnt a problem with my cubasis 32 bit version running on my ipad mini on ios 9.3.5. Looks like its specific to ios 10

Ok, i registered as a dev. Now its logged. Lets see what happens.

32181977 Behringer UCA222 sound hangs with core midi clock output

Hi Richtowns,

Please let Behringer know that we’re fine to support them with a Cubasis promo code if required.
In this case, please let me know about the contact via private message.

Thanks,
Lars

I have a new behringer (although I doubt its authenticity) UCA222 and using this one I cant replicate my problem, so it looks like my original is blown/worn out. It is strange that it works perfectly while using on my ipad mini on 9.3.5. Anyway, Ive closed my apple dev bug report (including the sysdiagnose logs for completeness).
Ill pop a label on my old uca222 saying ‘not ios 10 friendly’. Sorry if I hijaked this thread, my intentions were good!
rich

Thanks for the update Rich.
Good to hear that the issue seems to be solved by using a new Behringer device.

Best,
Lars