SOLVED: No sound when connected to Built-in Audio | MacOS

Updating the post with the solution for future users:

Steinberg and Apple both acknoledge the fact the feature of switching between headphones and laptop speakers on a mac with Cubase is not a right-out-of-the-box thing.

Steinberg says:

  1. Create an Aggregate Device on your Mac and selecte it in Cubase under Studio ▸ Studio Setup ▸ VST Audio System ▸ ASIO Driver.

Follow this link for their full article:

Apple says:
Create an Aggregate Device following this guide:


Follow this link for their full artice:

I simply created the Aggregate Device (using Apple’s guide) while the headphones were plugged in and next time I opened Cubase it recognized the system and now I can disconnect and reconnect the headphones and Cubase responds accordingly.
I named the aggregate device “Just Macbook”.
Now my audio connections looks like this:

Hope anyone would benefit from it!

Original Post:

The situation:
I’m on my Macbook Pro working remotely , not connected to any external audio interface, Wanting to hear the sound from the headphones. Normally I am connected to one.

What I tried:

  1. I opened Cubase with the headphones connected and sound came out from the speakers, not the headphones.
  2. I closed Cubase and re-opened it with the headphones disconnected - No sound whatsoever.
  3. Now the project is playing but the Stereo Out fader indicates nothing is playing. as if everything is on mute.

Can anyone explain what’s going on?

I could wrong but i think when you connect headphones you get another item to select instead of built in audio. There should be a headphone option in that drop down. Select that instead of built in audio.

Hey, thanks for the reply!

Didn’t find this but just restarted Cubase with the headphones plugged in and suddenly it worked. Weird because it just sorted itself, I didn’t do anything new. I’m happy though, problem disappeared!

1 Like

I have had that issue before and i just reopen Cubase with my headphones plugged in and its okay. Same as you are doing now :slight_smile:

I just tested it on Macos 14 and that issue seems to be resolved which is great. Not that i would advise upgrading but nice to know that it will be much smoother.

1 Like

Thanks for the tip! Just upgraded too. :slight_smile:

Headphones were not connected and sound came out from speakers. Then connected them - sound came out from the headphones.
I disconnected them again to confirm it always works but sadly when I connected them again for the 2nd time - Cubase continued playing the sound from the speakers.
Then shut down Cubase and reopened with the headphones - the sound came out from the speakers.
Then connected again and sound from the headphones

Seems to me the solution is simply to connect the headphones after opening Cubase.

Hey @RTT1 , I figured it out, Check out the original post!

1 Like

Perfect ! Thanks for that. I shall make an aggregate and use that instead :grinning:

Thanks for the solution

1 Like

I forget every time but plug your headphones in and goto the studio thing where the built in driver is then click on control panel and a tiny window will open up and if you scroll on the right hand side of it you can select the output from the Mac in built audio device to be Headphones.
No need whatsoever for aggregate devices.

Then press F4 and make sure your outputs are set as always.

1 Like