[SOLVED] Output to PDF changes font weight?

In Dorico I have my lyrics set to 9.8 point Minion Pro, fixed size. But when I output to PDF, the font weight is significantly heavier. And when I analyze it in Acrobat Pro, it tells me the font is “*Minion Pro-1959.” (With the asterisk). Same with title font. When I highlight the text and change it to Minion Pro, it looks correct.

Any idea what’s going on here? It seems all text is undergoing some sort of transformation during output. I need to match an existing set of scores precisely. Thanks!

Edit: a Google search tells me it’s the computer not recognizing the font as installed. But it IS installed…

Something similar happened to me, maybe my solution can help you.

Depending on how the font and the font weight are named and grouped it can be that Dorico does not recognize a particular font weight.
For example on my system Dorico cannot PDF output correctly the italic weight of a Swiss font.
I can vaguely remember that this happens also with Minion Pro.

You have to look in a font editor how the font weights are named and give each weight a distinct name, do not rely on a sub family name to differentiate the fonts weights.
Reinstall the fonts.
Then in Dorico choose the desired font and use regular as Dorico style.
It should work.

Two issues which might be relevant:

Fonts in PDFs are usually given unique names (by adding letters or numbers), in order to make sure that font is referenced by the renderer, rather than a system font with the same name.

Dorico offers you “Bold, Italic, Bold Italic and Regular” for every font, even if that style is not installed or does not exist. It may be that you’re selecting a style that you don’t actually have. I don’t know whether Dorico ‘fakes’ the missing Style by thickening the stroke or slanting the characters, which is what apps used to do in the 90s. :smiley:

In general fonts with multiple weights work very well in Dorico, but things can get complicated on Windows. The attached Dorico project and PDF was made on Mac. On Mac, fonts can have a variety of style/weight names beyond the standard bold/italic/bold italic options, whereas on Windows there is not the same kind of support for these extended style names, so instead of fonts with a single family name “Minion Pro” and then many style names like “Semibold” or whatever, you end up with multiple font families named “Minion Pro”, “Minion Pro Semibold”, “Minion Pro Medium” etc., and the same old style names “Regular” and “Italic”.

The underlying Qt framework tries its best to help resolve these issues in a cross-platform way, but there is so much variation in font naming that things can still go wrong!

It is still the case that if you try to choose (say) the bold weight of a font that doesn’t have one, the system will synthesise one for you, and that can also result in some weird-looking and ugly results. In those cases, try to find a real bold weight etc. for the font you want to use, or use a different font that does provide one.
minion-pro-test.zip (580 KB)

Thanks for the replies, Daniel and teacue. In this case though, it is just Minion Pro, regular. No bold or semi-bold or anything else. No matter what I try, Dorico outputs Minion Pro incorrectly, even though it is installed on my system. It comes out as a heavy, thick typeface, completely different from what I’m inputting.

Any suggestions on how to resolve this? I use Minion Pro as my go-to house font, and I need to be able to match existing output exactly.

Daniel, perhaps if you could direct me towards some font gurus, I’d be happy to ask them. Maybe I could engineer a work-around as the program is maturing.

Dan, I’d be happy to look at a PDF with the problem and see if it suggests any course of action.

Wiggy, thanks for the offer. PDF is attached as a “zip.”

You can see I just used one of the default Dorico files, sans modification. No nothing weird about the fonts or anything.
document1.pdf.zip (278 KB)

UPDATE: It does this for all fonts. Every single PDF I create is exhibiting this strange behavior:

When I open it in Acrobat Pro and click on “Edit PDF,” it gives me a dialogue that says something like “converting scanned images to editable text.” That’s not right. And when I select any text, it says something like *Times New Roman-2338. I get that message no matter what font I use.

Then a box pops up with a place for me to check a box that says “Use system fonts.” And everything goes screwy. Even the music itself gets pixelated, like it’s an image file instead of a vectored font.

I’m lost. I’ve used Adobe to print to PDF for 20 years in all sorts of programs and never had this. Finale, Word, Excel, anything.

Are you using the Graphics Export option in print mode, or are you using the OS print menu to print?

If you are using the OS print menu, have you tried clicking the graphics tab on the right side panel in print mode, and using PDF as the graphic type to print? I have used the PDF export in Dorico for MANY things, and they all turn out great.

Your description above sounds like you have been using the OS dialog to export a PDF.


Thanks for the reply Robby. I literally just solved this five minutes ago!

You’re right, I have been printing using Adobe PDF. I exported as a graphic and it’s fine.

I confess I find the print dialog a little confusing. I’ve always used Print to PDF. But I just need to go read the manual. Facepalm. Didn’t think that would be the issue.


Glad you got it working!!! I had some print issues with version 1.0, but since the first update many of the issues went away.

I’m happy you solved this problem.