[SOLVED] possible bug loading instrument list

PART 1 - BUG DESCRIPTION
I crashed and relaunched Dorico. (see desc. below)
When I add a player and type “flute” into the search field the single instrument “flute” doesn’t show up in the list. Only “pan flute”, “alto flute”, etc. yet there is a blank blue empty selection at the top of the list. If I click add while the empty selection is highlighted then flute is correctly added to my score.

If I try to navigate to flute when adding a player, when I select woodwinds, again flute is missing from the list, but there is an empty selection at the top of the instrument list. Again, if I click add while the empty selection is highlighted then flute is correctly added to my score.

PART 2 - STEPS TO CRASH
1 - highlight entire score
2 - filter -> deselect only
3 - filter -> notes in chords -> top or single notes

I realize that I was trying to refine the selection of notes while everything in the score was selected, including clefs.

in the attached screenshots you can see the aforementioned lists with the missing “flute”




I will restart my computer to see if the bug goes away.

UPDATE
I just restarted my macbook and flute is still missing. this is Dorico version 2.2.20.1286

Sounds very odd. I’d restore the Dorico app from your backup or reinstall. It looks like the instruments data file might be corrupted.

Are those out-dated specs in your signature? MacOS 10.14.6 is the latest, and Dorico 2.2.20 is the last.

I just updated my profile to reflect that I have iOS 10.14.6 installed
I re-installed the “update to dorico pro 2.2.20” with the Steinberg dnld asst.
when I run Dorico it shows version 2.2.20.1286 (April 18, 2019)

I like the idea of a corrupted instrument data file. the re-update didn’t fix it, however. Any ideas besides a complete uninstall/reinstall?

I suspect you’ve used a flute in a previous project, then edited its name to " " and Saved as Default. Add the blank instrument from the top of the list to your current project, then edit its name to Flute, then Save as Default.
Then ensure you don’t do this again :wink:

thanks, pianoleo!
I must have done this while sleepwalking because I’m certain I haven’t known about this function until now. But it worked - the proof is in the tasting.