[Solved]Problem installing The Grand 2 with Cubase 5.5 64bit

First of all, I’m really sorry if this topic has been asked and answered before. The combination of my lack of aptitude in web search and my impatience urged me to put a post here. I appreciate any help in advance.

I’m currently running Windows7 64 bit. Before the 5.5x update, I was running 32bit version of Cubase5, and The Grand 2. I had no problem at all at this time, installation ran smoothly, everything worked perfectly except for memory limitation.
After 5.5x, I decide to move onto 64bit version. First I’ve uninstalled everything, just to be safe, and installed Cubase5 in 64bit, applied all the updates. No trouble at all. And then I tried to install The Grand 2, but failed with message saying some process is preventing The Grand 2 installer from continuing. I guessed it was probably driver related issue, so I disable eLLC, and then tried. This time the installation worked, and I applied the patches. After this, my system just refuses to recognize my eLicenser, preventing any of my programs that uses it.

I’ve un-installed everything and tried a few possible combination of installation order that I could think of, without result. I can’t seem to find a way to properly install and run my The Grand 2 with Cubase5.5x 64bit on Windows7 64bit.

Anyone here has similar issue? Is there a way to make this couple work, or do I have to upgrade to The Grand 3?

Thank you.

Hello ( and welcome ) !
I guess the Grand 2 should work with C 5.5 64bit .

If the USB licencer is not recognised by Windows un-plug it , restart and connect it again.
If it only appears in the Windows Device Manager try updating the Driver .
If the eLCC opens try updating it . It seems to want Administrator permission in Windows 7 , so when you open it from the Windows Start menu don’t left-click , but right-click instead and select " Run as Administrator " . Then , when it opens , select " Update eLicenser License Database " from the Support Menu . The current version ( here at least ) is eLC Version .
Check that your Grand licence appears in the eLCC , if not re-enter it’s Activation Code .
Re-boot and try starting Cubase …
( Installations seem to want Admin Permissions too ! )

Hope that helps .

Thank you so much for warm welcome, and super fast response!

I think I ran everything ‘as administrator’, but will try to follow your instructions and try everything again, to be sure.

Thank you! I’ll post the result of my trial soon.

I double-checked everything you said, which in fact was pretty much same with what I had tried, but I’m still having problems here. It seems that no matter what I try, at the point I’ve successfully installed The Grand 2, my system doesn’t recognize the eLicenser anymore. Could it be the driver problem?
I’m still trying to find any possible explanation and solution to that, and in the mean time, any help will be deeply appreciated!

I should have known… Thank you so much for those who spend their time to care about this topic.
Finally got the problem solved. Here’s the order of the things I’ve done.

  1. Uninstall Cubase5.5x 64bit and related eLicenser application and driver.
  2. Install The Grand 2 and all its available updates without rebooting. And then reboot.
  3. Uninstall eLicenser driver that came with Syncrosoft LCC. Uninstall LCC.
  4. Unplug the protection device and Reboot.
  5. Download latest version of eLicenser application and install it. Plug the protection device.

After that, The Grand 2 started to recognize the eLicenser again. And then I’ve installed the Cubase5.5 64bit. Everything’s working fine, for now, at least.

Hope this information helps anyone with similar problems in the future.

Before anyone else gets in such a mess with elicencer, just try installing an update for The Grand 2 with your disc in the drive and then loading the content manually. It works and it is a whole lot less hassle! Good luck folks!