[Solved] Problem recording midi with Oxygen 8 on Windows 10

Hi All,

I have a problem recording midi. I am a newbie to Cubase and just getting to know the program a bit more, so hopefully an easy fix. I have been able to set things up and made it work, but this problem is kind of wondrous. I have of course done my part trying to find a fix. Here are some steps for creating my problem

  • New project
    Add Instrument Track (Halion or Groove Agent)
    Choose whatever sound/kit
    Set locators between 2nd and 4th bar

Situation 1: (unexpected behavior)
Set cursor to zero and just hit record and play on oxygen 8 keyboard. I can hear sound, a track is created, but it has no content/recording.

Situation 2: (expected behavior)
Set cursor to zero and just hit record and play on the virtual keyboard in that transport. I can hear sound, a track is created, and it has content/recording.

Situation 3: (expected behavior)
Set cursor to zero and activate “cycle” in the transport just hit record and play on oxygen 8 keyboard. I can hear sound, a track is created, and between the locators content/recording shows.

Why does the midi in situation 1 not get recorded into the track when it does in situation 3?

What can I do/try to make situation 1 work?






System puts out sound with the midi keyboard (Oxygen 8).
I put in markers between bar 2 and 4 and now set to recording. A track is generated, but nothing gets inserted.
I rewcord again, but now use the virtual keyboard in the Transport. Now it does record.

Now the odd thing. When I turn the transport cycle on, I do get the midi recording and it works as expected. But I don’t want to cycle, but just do a simple direct recording.
Is there a setting that I am not aware of?

Remember, I am new to cubase.

Hi and welcome,

Isn’t Punch-In and Punch-Out enabled in your project? Can you send a screenshot, please?

Thank you Martin,

I came across this problem using punch in/out. After that I tried in numerous ways. With punch in/out and without. I am certain it jumped in recording mode when trying to fix and test.
Simply hitting record will not register the midi, though I can see response in the transport window.
Don’t know if it helps, but here is the screenshot.
Thanks

Your midi input is set to all midi inputs.
Change that to the actual midi input, or go to your midi settings and include the midi input in the “all midi inputs”

Thank you paekae,

The problem remains the same when changing the MIDI input to only the keyboard. There is a slight difference and that is that now the virtual keyboard is not recording. This would be expected. Still I get no midi data in normal recording, even though I hear the instrument when playing on the keyboard. I only get midi data when the cycle options in the transport is on.

I tested with the Oxygen 8 and looked in the MIDI setup. I can see that the keyboard is checked in “All Midi”.
I also unchecked it and tested and off course the “All Midi” setting did not trigger the midi sound where the keyboard input does. I set it the keyboard back into “All Midi” after my test.

So unfortunately it did not fix this. I hope you have other ideas, because I have run out of options. Still looking around, but I can’t find the fix.

What are your midi record modes set to? (Pg. 226 in manual)
Possibly multiple parts stacked and only seeing the top, empty one or other parts muted by a stacked, muted mode?
Midi channel mismatch? What are the midi channel assignments on the first two tracks? What channel is the oxygen sending on?

Hi jaslan,

Thanks for throwing some stuff at me.

First I looked at the manual, but somehow it does not seem to fit your comment. I look at the operation manual through the help menu and page 226 refers to the MixConsole.
Could you give me a link to the manual you are referring to? I am just starting off in Cubase, so pardon my lack of knowledge.

I was successful to track down what these midi recording modes are and I attached a screenshot on that.
For info sake I had put in 3 tracks n the first screenshot, but I had a single track during my troubleshoot. In normal recording it records nothing. It does record when in cycle mode and also step mode does register the midi data into the track.

For what the midi channel, I have my one track assigned to channel 1 as can be seen in the earlier screenshot.

What channel is the oxygen sending on? … I do not know this one.
midi-record-modes.jpg

Sorry about the page number mistake. I am using the C8 Pro manual and i see that you are using the elements manual so the page numbers wont match.
This is kind of a stumper that seems like it should be simple but i cant figure it out. Did you try some of the other recording modes in the non cycle recording modes. Also, just confirm that in ALL cases the record arm button in on (red).

Hi jaslan,

Yes, I did try and play with the recording modes. No results. I am sure it is armed and recording.

I am baffled myself. Why would the Oxygen record in cycle mode and not in single mode. Technically it does not make sense.
I remember I have an old midi interface, Midiman MidiSport2x2. The Oxygen has both USB connection and the old midi connectors. I will dig it up later today and see if it makes a difference.

Have you tried something like MIDI-OX to get some info of what is received from the keyboard ?
It’s a nice tool to have when having MIDI hiccups.
http://www.midiox.com/

peakae,

I installed MIDI-OX. I am not sure what to do with it. I can see some activity once I started to mess around with it, but I can’t tell what I am doing. I added a screenshot.
If you can help me what to check for, I’d appreciate it.

I dug up my Midiman MidiSport2x2 and now I got it to work through this device. Setting it up with the MidiSport2x2 interface was no trouble and it worked out of the box so to speak.
I still don’t understand why the Oxygen 8 doesn’t work with the USB connection. I do know the device it outdated, since the last driver is for Windows7.

What Windows version do you use?

Windows 10 (x64)

This actually could be a problem, if the driver is nit compatible.

Hi Martin,

Yes, it does seem to be the issue. Luckily the MidiSport2x2 is sporting me well. I was able to work with it yesterday and lay in my first drum beat. Good thing, because nothing is as frustrating as getting stuck at the very beginning.

Now that I started thinking in this direction I do find some more information. According to this a thread on M-audio it may work on a USB2.0 port.
http://community.m-audio.com/m-audio/topics/oxygen8_keyboard_not_detected_by_windows_8_1
I am not sure what what port I am connected with at the moment. I will give this a try later today and post my results.

In any case thank you all for trying to help me … :smiley:

I tried the Oxygen8 connecting it to a USB2.0 port and surprise, it works. It seems to be working normal. I can record in normal mode and cycle mode. Punch In/Out works as expected and it all seems very easy now. Just hook up, choose the device and play.

Windows 10 x64 + Oxygen8 + USB2.0 = works.

The driver for Windows 7 SP1 can be used and found under the legacy drivers on the M-audio site.

Thanks for the support here. In the end device related and not cubase.
I will leave a better title for those who run into this.

It’s a little scary, I was researching motherboards for a new PC build. And some of the newer ones don’t come with usb2 anymore, all usb3.
I know some usb2 hubs connected to a usb3 port make it work, but those are also slowly disappearing.

Nothing special. It’s the same for FireWire or some other old Ports, which are replaced by a new one. The old devices are not suppoerted anymore. Do you remember LPT port?

Scary is, some current products don’t support USB3.

Yes, together with the RS232 port and 5.25 Floppy discs… Haha … But no USB3.0 today is indeed scary. I will remember this warning. :open_mouth: