[solved] problem - restore purchases

Good day

I have purchased and installed cubasis 2 on my iPad and in-app purchases. I also bought Cubasis 3 and successfully performed CUBASIS IN-APP PURCHASE TRANSFER. I have also installed Cubasis 3 on my iPhone, but here the in-app purchase transfer fails. Cubasis writes: NOTHING TO RESTORE. Both devices are of course on the same Apple ID and I try it on the iPhone through the RESTORE PURCHASES option, because Cubasis 2 is not available for iPhone and it is not possible to use the CUBASIS IN-APP PURCHASE TRANSFER function.

I searched the web for various discussion forums, but found no solution. Thank you for the advice.

Hi bilbo07,

Thank you for your message.

When being logged in with the same App Store account on both devices, the transferred IAP’s should automatically appear on the iPhone version.

Please let me know if they do after some time.


Hi Lars,

thank you for your answer. It’s been about 24 hours so far. So I’ll try to wait a few days and let you know.

Hi Lars,
I was waiting for the announced update 3.0.2, hoping to resolve the IAP issue. Unfortunately the iPhone still voices Nothing to restore. Of course I use version 2.8.2 and 3.0.2 on the iPad. On iPhone only 3.0.2. Of course I’m on the same Apple ID. Is there a solution?

Thanks, Bilbo07

on my ipad pro, I installed cubasis 3 LE. On this side everything works very well. I bought the full version and I successfully transferred all the in-app purchased from Cubasis 2 LE. But! I also have an iPhone XR - everything seems to be working except for one thing. The full version does not work! and yet it says “bought” in the shop … and there is nothing else to do. I have tried everything. restarted the iphone, reinstalled the app … nothing helps. it clearly strikes me as a bug. thanks for getting back to me

I noticed that the In App transfer on the iPad was successful from Cubasis 2 to Cubasis 3 (In the iPad Cubasis 3 reports as Bought), but in the App store, In App purchases are still marked as not purchased. Can’t that be the reason that Cubasis 3 on iPhone still reports Nothing to restore? Will someone please help with this problem?

Hi bilbo07,

I’ve exchanged with our engineering regarding the topic.
Please check the steps below, and let us know if this helps to resolve the problem.

There are 2 places to log in with your Apple ID in the iOS Settings app:

  1. Under “iTunes & App Store” you log in for purchases
  2. At the top of the list you log in with your Apple ID for iCloud sync

Make sure that you are logged in at both places with the same Apple ID on both iPad and iPhone. Also make sure that in (2), “iCloud” is enabled.

When transferring your in-app purchases from Cubasis 2 to 3, Cubasis 3 cannot unlock these purchases on the App Store (Apple doesn’t grant apps this possibility). Instead, Cubasis 3 uses iCloud to sync your list of purchases across all your devices. Hence, iCloud must be enabled with the same Apple ID.


Thank you Lars,
I really haven’t activated iCloud on the iPad. After connecting to iCloud, In App sees purchases and iPhone. Please mark as solved problem. I hope this will help other users solving the same problem.

Perfect! Thanks for the update, bilbo07!

Glad to read that the tip from our engineers helped to resolve the problem.

Stay well,