[solved] problem with hiding empty staves


in my second flow the TENORE 2 is still showing up in the first system, even if I have disabled it in Layout options. This line is completely empty until bar 265 at the end of that flow.

Obscurely, I played with Layout Options “Hide Empty Staves”: If I apply “After First System” this will only apply to the second flow, not to the first, not to the third flow and any more following it. When I apply back the “Hide empty staves - All systems” TENORE 2 gets stuck at flow 2 first system…

Is there a way to fix this?

Obvious question number 1: Is this an imported XML? If so, delete the clef at the start of the flow.
Obvious question number 2: Are you definitely selecting the correct layout on the left hand side of Layout Options?

thank you for your reply!
Yes, I have chosen the right layout and no, the project had been created in Dorico.
The only things I changed in Setup Mode was moving TENORE 2 to a new player. I had that line as a second instrument to TENORE and later decided to give it a seperate player. But as I did the same with BASSO 2 and BASSO (where everything looks fine) I cannot find a reason for Dorico having a hiccup here…
the TENORE choir part splits into two lines for the last 8 bars of the second flow; so does the BASSO.

Can you attach the project so we can take a look at it? Feel free to delete all of the music except the minimal amount that allows us to reproduce the problem.

Thank you Daniel.
In the mean time I had been able to fix the issue in a very simple way (deleting and re-inputting):
I deleted the TENORE 2 player from the Setup Menu,
closed Dorico (not sure whether it was necessary), reopened,
added player Tenor again, edited it’s name and
input the 8 bars of music into that line :wink:
Everything is fine now.