[Solved] Sound card driver not detected

Hi everyone

I’m a novice when it comes to both cubase and sound cards, so please bear with me. I did a forums search, but didn’t find anything that helped me. If I overlooked something I appologize.

I recently bought a Steinberg UR22 mkII, and installed the Cubase AI bundle that came with it. I am currently using WIndows 10, Cubase LE AI Elements 9.5.30, and the latest sound card drivers from Steinberg.

At first everything worked fine, but now whenever I start cubase it doesn’t find the sound card. I do not get any warnings or errors. All audio is played from my computer speakers, rather than the headphones connected to the sound card, and I cannot record any audio.

In the studio->Audio connections menu I see it has selected “Generic Low Latency ASIO driver”. There are no other device drivers available from the drop-down menu.
If I hold CTRL+ALT+Shift on startup, and Delete program preferences, it detects the Yamaha Steinberg USB ASIO, and I can choose it as my audio hardware. After that everything works as expected, and the correct device shows up in the Studio->Audio connections menu.

However if I simply close Cubase, and start it again, without unplugging anything, only “Generic Low Latency ASIO driver” is available.
Having to delete program preferences on every startup quickly gets tedious very quckly.

The only thing I can think of that I did before this problem began, was starting a cubase project without the sound card connected. I got a few error messages regarding audio channel routing. I simply pressed cancel and closed Cubase.

I have tried removing and reinstalling the Steinberg sound card drivers, but the problem persists.

Any help is much appreciated.

Update:
I found drivers named Generic low latency ASIO driver in a Steinberg folder in the start menu. I uninstalled it and that seems to have resolved the issue. Now every time I start the UR22 is correctly set as my audio device.

Click on the white waveform symbol in the studio setup, and there she are
I just Search after it

Geert

Hi! I’m having the same problem, could you go into more detail on where to find those drivers and how to uninstall them? My card is a Mackie ONYX 400F, and i have windows 10. My computer detects the card, and it plays sound on my headphones, but Cubase doesn’t appear to detect it.