[SOLVED] Soundiron Olympus Choir Micro not installed?

In Setup mode I choose a normal SATB choir, but Olympus Choir Micro does not load and seems not to have been installed…

The playback template gives me 3 options:

  1. HSSE (Elements)
  2. HSSE + HSO (Pro)
  3. Silence

Did something go wrong with the installation of Dorico Pro 3?
My download of Dorico Pro 3 Sounds Installer is 9.98 GB.
I’m on Windows 10 (full specs in my signature).

Any suggestions? Thanks in advance.

Edit: Watched the Dorico 3 YouTube tutorial on choirs. Olympus Choir Micro did not load automatically! I had to load it in Hallion Sonic SE3 first. A bit confusing though and I hope I do not have to do this every time I choose a choir or solo singer.

1 Like

Please have a look at this thread: https://www.steinberg.net/forums/viewtopic.php?f=246&t=167681

Ulf, thanks for your addtional info.
I solved the problem in the meantime, but good to know.
However the VST does NOT load automatically as stated in the YouTube tutorial, or am I mistaken?

There’s no dedicated VST plug-in for Olympus Choir Micro: the sounds load into HSSE3. And there’s no need for a dedicated playback template for it, either: the vocal sounds are loaded by either the ‘HSSE (Elements)’ or ‘HSSE+HSO (Pro)’ playback templates without you having to take any further action.

Daniel, thanks for explaining. Have a good day.

Franklin