[SOLVED] Steinberg plugins - text only interface no option to switch to Plug-In Editor

All of the Steinberg plugins have suddenly started to appear like the image below. All text parameters and no interface.

This is happening in old projects and brand new empty projects.

Is there a setting to change this or is my Cubase 12 broken?

Windows 11
Cubase Pro 12.0.70

Try to right click on the plugin window and set it back to Plug-In Editor.
grafik

In case you don’t have that menu entry, install Cubase again.

The arrow after the camera: click on it and select in the drop down menu: Switch to plug in editor.
Have a good day :slight_smile:

Hi I tried both ways but this is the context menu I see… no option for Switch to Plug-in Editor. Do you think I need to re-install Cubase?

image

Hi,

It’s worth to try. Install it as administrator, please.

Hello sorry for the delay only just got back to my studio.

I can confirm the following steps for reinstall worked. Note just installing again from within the Download assistant did not work for me.

Hope I do not have this issue again but here are the steps to try for anyone else who runs into this strange glitch.

  1. Open Steinberg Download Assistant
  2. Click the drop down next to Cubase 12 Installer and select Open Folder
  3. Extract Cubase installer
  4. Run Setup as Administrator
  5. Select reinstall for Cubase and Components
  6. During install it needs to reboot
  7. On reboot Cubase 12 is removed
  8. Open installer again as Administrator
  9. Select install for Cubase and Reinstall for Components
  10. Once finished open Cubase 12 and Steinberg plugins now have their GUI.

@Martin.Jirsak
Is Steinberg aware of this issue? Any comment from their side? This is not the first time somebody reports it. It would be nice to know if there is a less invasive solution than re-installing Cubase.

This is one of the Cubase issues that indicates that the Steinberg devs have lost control over the program.

1 Like

Hi,

Is this a generic issue? Is it reproducible, please?

A search on this forum would reveal that it occassionally it happens to customers. I don’t believe any star constellation has anything to do with it.

If I’m being honest I am very disappointed by your reply where you indicate that you can’t remember having seen this issue being raised before.

Hi,

OK, I didn’t know. This is, why I was asking.

Sorry, I can’t read all the reports and I can’t even remember all the reports I was participating in. Therefore I asked if someone else had this knowledge.

Thank you for pointing to the fact, there are more reports like this.

Do you mean exactly like this? With this specific menu and entry? Or do you mean similar reports, please?

Hi Martin and Johnny, I remembered my answer to a pretty similar thread, perhaps this would be of help, either for debugging purposes or even for a utility addition in Cubase to restore this state:

2 Likes

Thanks for pointing this out.

Me saying that Cubase got out of control from the devs is basically wondering why the file AudioPlugs.srf gets corrupted by anything that we do as a user inside Cubase.
Something like this should simply not happen under any circumstances (other than a virus attack).

I am not getting worked up because of that inconvenience with the plugin editor. It is that this kind of stuff runs through the entire application and symptoms of it pop up like mushrooms.

SOLVED. None of my stock plugins nor my meters in the right pane were showing up as GUIs. I downloaded the Cubase 12 Pro installer from the Steinberg Download website at Downloads | Steinberg.

Once downloaded, I opened it as an administrator and chose “Reinstall Cubase 12.”

After it installed, everything was back. Very simple fix. Hope this helps someone else!