[SOLVED] Sustain pedal on keyboard controller muting track

Have a problem that just started: when I use the sustain pedal on my MIDI controller keyboard (Roland A-800Pro) it mutes the instrument track. I put MIDI Monitor on the track and I see it transmit on CC64 like it should for the sustain pedal (127 when engaged, 0 when released), but it is muting the track. How to I get the Mute function from responding to CC64, or is something else going on?
Thanks

The first thing that comes to mind is that there is something fishy in either an active Generic Remote definition, or a Input transformer setup. Beside this… :confused:

1 Like

Thanks cubic13. Yes, it dawned on me finally the Generic Remote would be a good place to look. I had been working with setting up a couple of the controls to work in the mixer the other day, but was only using the first 5 or 6 controls. However, when I scrolled down a little while ago, all the mutes were set to CC64. Not sure how I managed to do that - some strange toggle? So I set them all to CC14 which is unused and now my sustain pedal is working properly again.

Glad that you got it solved. :slight_smile: Beside this, the whole Generic Remote feature is a great one, but plagued with several bugs that never have been solved. Be sure to ALWAYS save the definitions you have been working on : it’s the key to make it (more or less) work as expected (beside, among others, the NRPN messages not recognized or an attempt to add a strip which will bork the whole mixer configuration). Still waiting, after all these years, for a complete overhaul of it… :unamused:

Good advice. I’ll do that right now.