[SOLVED] UR22 mkII No Input after Win 10 Update

Hello everyone,

2 days ago I installed new Win 10 updates and just found out that Windows doesn’t see my microphone input in UR22 mkII. I tried to reinstall the driver, didn’t help. If I switch the knob on the sound card from DAW to Input, I actually CAN hear the mic, but not when switched to DAW. Doesn’t work in Cubase, nor Skype or any other application. Any thoughts pls?

Make sure you are using the latest driver, there is a compatibility issue with earlier drivers.

Hey peakae,
I am using the latest drivers, always. But now, I managed somehow to make the mic work in Cubase, but not in windows or skype.

I’ve solved it. What an incredibly stupid solution. After the new Win 10 update and after GDPR at work, Windows asked me what I will allow him to access and I told him I don’t want any program to access my microphone. I just reverted this option and it works. But I will probably not understand how could Cubase access my microphone when Windows and any other application was not allowed to. Anyways, problem solved.

Cubase uses ASIO, that is completely different from the Windows sound system.
ASIO is communicating with the hardware more directly and takes over.

I have a similar issue, I connected a marantz MPM-3000 to the UR22, tapped the mic and had an input, when I restarted windows it did some updates but now there is no Mic input detected, audacity and cubase elements 9.5 see the steinberg ur22 but there is no input from Mic
I cant find any settings to suggest it has been blocked, Al firewalls are off etc
what settings did you change to enable mic access in your issue

It’s in the Privacy settings.