[solved]UR22 output works in Ableton 11 Macbook M1, but not the inputs!

Hi all,
got a MacBook Air M1 to replace my windows laptop, but keeping my UR22.
Installed latest driver and output worked flawlesly.
But today I tried to record some inputs in ABLETON 11 and the inputs are not working.
If I turn the input/daw wheel to input I can hear the sound, so it’s not a “instrument” problem.
But it sound is not coming into ableton.

Ableton settings → Core Audio,
input Steinberg UR22 (2in, 2out) , Output Steinberg UR22 (2in, 2out)

Thanks a lot!!!

Self-reply after some troubleshooting.
First, is not an UR22 problem. Sorry. It’s an Ableton issue.

Ableton auto-update changes the app executable file , and this new one does not inherit the “mic access permission”.
Even if you enable manually, it does not work.
The only solution I’ve found is reinstall & disable autoupdate, so I have to update it manually from time to time.
I hope it helps you.

Hey!

I am having the exact same issue, even after changing the microphone acces in privacy still no sound input to ableton. Can you give a bit more detail about how you solved this issue? Is the only fix just uninstalling? If so what should I do differently next install?

Thanks for reading.

Hi @bludworkmusic .
Do the UR22 works with other apps? If not, Macos should prompt you at boot for authorization for the UR22 module, so the only way I got this window is uninstall / rebooting / install / check permissions / reboot and then the prompt windows pops at boot time.
If the prompt window does not appear, do it again! I’m trying to recall it from my memory, I think these are the correct steps.