[SOLVED] VST Performer version check crashes on Windows 10

In VST Performer, to check the version you click on the words “VST CONNECT PERFORMER” in the bottom right-hand corner.

I’ve had a number of cases where, following a new install on Windows 10 even with the latest version, the first click briefly flashes the version information, but the second click causes the application to simply disappear; earlier versions just disappeared with a single click.

Having the same version at both ends is advisable, but trying to check the version of the performer crashes the application.

Not surprised. I just tried using the program with a musician buddy and we couldn’t get past square one. I’d be delighted to see some decent explanation as to how the thing works. Like all things Steinberg, unless you’re a sound engineer, they could care less. Give us some decent documentation we can ALL understand, not just the pros!!!

hi Lee

instead of just posting to complain why not post a thread asking some questions about how to use it and any problems you are having ? - then people will help out

Yes, then they will. check here: https://helpcenter.steinberg.de/hc/en-us/articles/360012899079

Had you been connected? Or did anything else after starting Performer? Can’t reproduce this.

No, I just start Performer and click twice on the words “VST Connect Performer”. I have a Windows 10 laptop here with which I can reproduce this every time. I’ll see if I can get a second laptop to try it out.

[UPDATE:] Tried it on a second Windows 10 laptop, same thing, 100% reproducible. After starting Performer, do nothing except click once, then a second time on the words “VST CONNECT PERFORMER”. If I first click on something else (e.g. the mixer view or setup) then the crash does not happen. Not a major issue, but does not build confidence with the performer :blush:

I cannot reproduce this on two different Win 10 machines.
But we’re on 4.0.44 already which is scheduled for publication soon, give that one a try then. We did fix some UI crash which might be related.

Hi MrSoundman,

we’ve found the problem and fixed it. The fix will be available with the next version : 4.0.44

Thank you for reporting,
Have a nice day,

Yay! :smiley:

I can confirm that this is now fixed in 4.0.44 in all cases I have tested. Well done!