SOLVED! - WaveLab STUDIO 6 not reading license !

:laughing: Re-installed after at least 10 years.

Installation fine but I now get:

Application ‘WaveLab STUDIO 6.x’ has caused the following error:

eLicenser(s) contain(s) no valid license for this application.


  • For troubleshooting information click .
  • Click to view available licenses.
  • Connect a valid eLicenser and click .
  • Click to abort.

Please note: I already re-installed Cubase 4 + eLicenser [latest version] and ALL works the WaveLab 6 licence is listed and active - I also re-checked my Steinberg account - activated.

I am on a Windows 10 Pro 64bit and I also ‘obviously’ tried the Windows Vista and 7 Runs - no change.

I believe the problem resides within the WaveLab connector to the licenser !

What do I do?

Thank you

In the meantime I am doing some more tries

All this after I managed to install WaveLab6 from Steinberg website download.

So, I thought to uninstall it and instead install from Original CD … far worse situation!

I now get: Please quit all applications using a dongle, then remove all dongles connected to your computer, then click OK
Nothing is connected and nothing related is running, but keeps bothering me with the above warning!

Flipping 'eck.

[NO, I cannot afford to buy a new version, why should I if this has never been used?]

I also set the .exe from CD to run as Windows vista! No change.

Steingberg, please supply an installer that installs from CD + connects to latest eLicenser !

Thank you

Wasting my day off [hours] trying to do what should be ‘easy’ to do - even for a seasoned Advancer Computer user!

I have WaveLab STUDIO 6 - i.e. the studio version and on Steinberg website there is ONLY the PATCH and NOT the full installer, while there is one for WaveLab 6!

Therefore the version that installed and was not accepting or finding license was the wrong installer!

Is Steinberg doing it on purpose?

There is NO installer on Download page for WaveLab Studio 6, ONLY a patch.

Therefore I am now officially stuck.

Got it now.

  1. uninstall latest or any eLicenser
  2. USe CD and install WLS6 - click all ok etc. - it will eventually install it!
  3. install patch from steinberg website download page - login
  4. re-install eLicencer


I just re-installed it in Nov 2022 and had the same problem.

Wasted another hour only to find MY OWN answer as nobody helped at the time.

I hope my answer helped other people!

BUT … this time is still doing the same … then the ‘Plug-in the dongle or Hardware Key’ appears.

So WAIT … and it installs or so it seems.
Now rebooting - old style!

:crossed_fingers::crossed_fingers: wish me luck!

Still in deep POOP!

Now it does not even start properly! hahahahaha

Giving: a referral was returned from the server
What a farce!

Yes, I have also installed the latest eLicenser and done maintenance.

CUBASE Studio 4 updated to 4.5 works fine, though.

I already repeated the previous steps several times and I AM TIRED OF THIS.

You could have solved this many years ago, by simply ‘amending’ your Setup.exe and you DID NOT CARE to do it.

Spent around £. 400-450 at the time…

Please note that Wavelab 6 was released back in 2006, during the Windows XP era. It’s over 16 years old. The newest OS it officially supported was Windows Vista.

An unsupported installer for Windows 7 is available here:

“A referral was returned from the server” is a Windows error. You might be getting it because you disabled UAC. You can try either re-enabling it or running Wavelab 6 as Administrator.

1 Like

Unfortunately already tried, thanks for helping.

I just re-run it again as admin, same.

Trying to find what I did last time - 4 years ago!

Will try that link.

Strange, really strange!I actually did install with that unsupported version.

Then what I did now was to install on top of it and it works!

I also strangely found a 2nd eLicencer with a (!) - I unistalled it and deleted driver and left the supposed to be newer.
I imagine eLicencer did not uninstall old version.

It may have been that.

Good for others, this thread.

Thanks for pushing me in going back to that version.

Better laugh than cry!
Started fine earlier.

Now I get the infamous:
application wavelab studio 6.x has caused the following error: Process with the ID NOT found


Runtime error!
Program: C:\Program Fi…

This application has requested the runtime to terminate it in an unusual way.
Please contact the application’s support team for more information.

The support team wants me to buy newer version, I do not need, that is why they never fixed it!

I guess I am forced to use Audacity or any other Open Source or similar.
Maybe it needs a Visual C++ update?


I forgot to set it to run as Windows 7.

Now starts again, let’s see for how long.

Then I imported an audio file created by Cubase - from a MIDI group of tracks and I got another error and shut down.

Now it does not start again.

What a farce and WILL NOT BUY a new version.

Good bye Steinberg.

ADDITION: even Cubase Studio 4 was not starting ‘this time’! So, I set it as W7 ans starts … for now.
Once again: what a farce!

Every new version of Windows makes compatibility with legacy software worse, and you’re using an Operating System that’s 4 versions newer than the one Wavelab 6 was programmed for. I don’t know what you’re expecting from software that’s almost old enough to go to college. A lot of stuff from that time by other developers wont even install on Windows 10 at all.

It’s Microsoft’s changes to Windows that broke compatibility with this old software. If you want to use Wavelab, either find a Windows XP/Vista computer or buy a version that’s compatible with Windows 10 (by the way, both versions of Wavelab are currently 50% off and no longer require the USB dongle).

1 Like

Actually, I do have 95% of my ‘old’ software installed on Windows 10.

I understand what you say - times change, but this program could have been officially modified the exe to W7 and would probably have worked fine.

Audacity works fine and it is free and getting better.

Not worth spending money on Steinberg any more. Cubase ‘just’ works, as I see once in a while does not even start.

Other thing Steinberg could have done is to ‘self-contain’ the exe and actually keep it outside Windows hands, with the exceptions of whatever it needed.

Bear in mind, it did install the first time from the ‘old’ disk and I do not remember why I had to uninstall it. Then all problems started.

Yes, I do have some computers on XP, Ubuntu etc. - so, all it is doable.
I guess the main problem is the ‘hardware key’ in my view that creates the installing problems!

Also and did forget to mention the obvious, we are now in a throw-away culture forcing people on ‘monthly’ - just to be in our pockets all the time and control us as well - constantly connected - software Companies need to obsolete software to sell new one, with Microsoft excuse!

I would have expected WL 6 to work actually. I know WL 6 ran on a 64 bit system OK.

If you feel it is a licensing issue, if you haven’t done so, perhaps download the latest Activation Manager and see if that does the trick.