SOLVED - WL10 Loops not working in Omnisphere. WL9.5 worked.

I mainly use WaveLab for making loops in samples I import into Omnisphere. It works fine in 9.5, but it doesn’t work in 10. The files imported into Omnisphere are not looped.
I dont know if Steinberg has changed the way the loop points are saved in the wav file, but that is where I think the problem is.
I use WaveLab Elements 9.5 and 10. The files are saved as wav files 48/16.

The files imported into Omnisphere are not looped

What do you mean? The markers are not imported?

I am not sure what exactly happens (probably the markers), but its not looping if I import a looped WL10 wav file into Omnisphere. If I open the WL10 wav file in 9.5 and save it, then it works when imported to Omnisphere.

I don’t understand your report. There is not such thing as a looped file. There are loop markers, on one hand (the green markers), and playback looping on another hand. This last one needs to be activated on the WaveLab Transport bar.
Given this, where is the problem you observe?

Yes I mean the green loop markers. I mark loop start and loop end and tweak it. I use it for looping instrument sounds to be used in other instruments that can play them (Omnisphere, Kontakt, etc.). Then the loops makes it possible to hold the played notes forever.

Then, where is the exact problem? Please describe a step by step procedure that works in 9.5 but not in 10.

I open a sample. Fix the offset, normalize to -1dB. Add a left loop marker. Add a right loop marker. Adjust the loop in Tweaker. Adds a short fade in at the start, so I am sure it starts and 0dB. Adds a fade out at the end. And save it as a Wav file.

When this is done with WL10 and I import it to Omnisphere, it does not react to the loop set in the file, and it just plays the sample to the end and stops.

If I do exactly the same in WaveLab 9.5 it works in Omnisphere where it plays the sample from the start and repeats continusly from the loop end to the loop start.

And if I take a saved WaveLab 10 file which doesn’t work in Omnisphere, and open it in WaveLab 9.5 and save it. Then it works in Omnisphere.

So the problem is it doesnt work saving this with WaveLab 10 when you need to use the edited sample in other programs. Thats the only reason I use WaveLab. Because it can (or could) do this.

I think this is simply because you don’t have the same marker options in 9.5 and 10.
See the following options. Set them the same in WaveLab 10 as in 9.5, and it should work.

Thanks, I did hope it was that simple, but no. My settings are the same in 9.5 and 10. I even imported the 9.5 settings when I installed 10 and was asked that.
Here is a screenshot of my settings in 10.

I see I still have the “Write Markers in WAV File Header (BWD Format)” on. So I wanted to test it by switching it off, but now Wavelab crashes each time I go to those settings. The WL window just disappears. Just tried reinstalling (forced the reinstall of both WL and the generic driver lower latency ASIO driver). Still crashes. Guess its not my day today :-/

Erase these preferences then.
\AppData\Roaming\Steinberg\WaveLab Pro 10.0\Preferences\General.dat

I will try that when I get home tonight, and report back. Thank you.

At first that didn’t work. Still crashed.
So I uninstalled and removed the settings folder (the path you specified above, but the whole folder this time), and installed it again and updated it to 10.0.5 (build 25).
Again it crashed when going to those settings.
Then I tried setting it with another soundcard and then it did not crash when going to the setting.
So now I have changed what you said I should change (and I even toggled the other settings to make sure they were stored), and now the loop markers work in Omnipshere.

So thank you very much.