Some Audio Files don't drag&drop into the Timeline in Cubase 10 (also 10.0.10)

Noticed this odd behaviour in Cubase 10:

When you want to import an audio file that resides on a Network volume, the file simply doesn’t import into the Timeline.

Here’s a clip:

When I put the same audio file on my Desktop however, it imports fine. So I guess this has to do with Network volume sharing somehow…

OK, so I just moved this WAV file into my project folder which ALSO resides on a second network volume and it worked importing it from there. I restarted my Computer and the problem is still the same. I simply cannot import the file from my Sound Library volume, but from my Project Library volume it works fine. Both volumes are on the same SMB server…

Third reboot and remounted all my Volumes…the problem still persists. Can it be the long name and deep folder structure?

Well would you look at that…I made a copy of the file and renamed it into something else.

original filename:
Impact Chain Small Metal Chain Drop On Metal 01.wav

renamed versions I tried:
Impact Chain Small Metal Chain Drop On Metal 01-02.wav

now it imports fine!

Not sure what is going on here.