Some H7 libraries don't work dongleless

I have both Cubase Pro 12 and HALion 7, but the following libraries don’t work dongleless in H7:

Alto Glockenspiel
HALion Symphonic Orchestra
Hot Brass
Studio Strings

They work when I put the dongle in instead.

I’d have thought this is normal for the 1st and the 2nd one, as they have a red circle in Mediabay:

but the others don’t have it :

when I try to load a preset, a “No license found” message appears though:

Any thoughts?

1 Like

Same for many of us.
I think it is just a matter of time until they move these packs… but exact date stays in the uncertain darky twilight zone :frowning:

Yes thanks that I already knew, what is strange to me is the different behavior of HSO from the other libraries (red circles vs no red circles in Mediabay).

A lot of that stuff should certainly be working.

Mine looked like that at first, but it settled itself over some time.

Try the following:

  1. Reboot.

  2. Load HALion stand alone and just let it sit for a while (give the new media bay time to go though everything and build itself).

If that doesn’t sort it out after some time…double check that you took the content updates in Steinberg Download Assistant.

If you did for sure…you might try grabbing the full content from the H7 section and reinstalling it.

HSO is working for me as well, but I also have Dorico installed…and Dorico in SDA updated HSO vstsound files back when version 4 was released.

1 Like

thanks I’ll try your suggestions

Oh, I should add…

I never got vouchers for my old HSO key to move to the new licensing system.

It works for me dongle free because of Dorico no doubt.

Do check your MyStenberg account every so often to see if you get vouchers to move to the new system.

I got some for GA and they work like this.

Get a voucher in MySteniberg account.
Click a link there and it guides you through it.

Essentially, you need your dongle plugged in to complete the voucher.

End result, is the key on your dongle gets tagged and renamed so it can’t be applied again by someone else on a different account. That key is still good if you ever need to ‘roll back’ to dongle versions of software…

The content key also gets added to your new Licensing Activation center. You’ll need to activate it for the machine just like you did for Cubase/HALion/Etc.

Yes, I already did that for Wavelab Pro 11.1. Unfortunately no new vouchers om my MySteinberg account…

Yeah, I guess we wait until the vouchers come…until then, need the old keys (dongle or soft-eLicenser).

Have you updated your ‘updates’ VST content in SDA

Yes thanks, that was the 1st thing I did before the update

Since the non-working libraries come all from HALion 6, I think the best advice is one from Brian_Roland, i.e. downloading the 30 GB full H7 content and reinstalling it. I’ve just started downloading (10 hours estimated…). I’ll let you know…

At last! I’ve downloaded the full 33 GB HALion 7 content. Double clicked on one the problematic libraries files inside the ISO file, a dialog window appeared asking me to install all the five culprits. Re-install went ok.
Inside HALion and HALion Sonic, when I loaded a preset at first I got the same “No license found” message, but after closing and reopening the program it worked instead, but just for the previously loaded library. So I loaded a preset of the next library → No license found message → close → open the program → ok it worked.

I had to do that for all the 5 libraries, on HALion 7 and then on HALion Sonic 7 too! What a mess!

Now I’m up and running though…

1 Like

OK, for those with the same/a similar problem, here you are the exact steps (Windows - Mac I don’t know):

  1. Here Download HALion 7 · complete content · ISO · 35.7 GB

  2. Double click the downloaded ISO file: the ISO is mounted on a virtual drive and its content is shown in Explorer

  3. Double click one of the problematic files, for example FCP_SMT_203_HS_Eagle_01.vstsound; this dialogue then appears:

don’t change anything and click ok. Then the window changes like this:

then this:

  1. Now, open HALion 7 and load a preset from one of the unregistered libraries. A red circle at the right of the preset name and the No License Found message appear:

  2. Close HALion 7, open it back and, again, load a preset from the same unregistered library. Now it works!

  3. Again, load a preset from one of the other unregistered libraries: it doesn’ work! Close and re-open HALion 7: now it works.

  4. Repeat for all the remaining unregistered libraries, in HALion 7 and also in HALion Sonic 7 (if installed)

Job done! Many thanks to Brian_Roland for helping me find the solution.

Unfortunately that doesn’t work for med because when clicking on the vst sond files it always states “no action performed! The corresponding VST Sounds are already registered”

Win or Mac? And which library(ies) are you trying to register?

Same issues here , I update the Steinberg Library Manager and it seems to work fine now!

I had this issue with those HALion libraries via Absolute. I just deactivated the license via the Steinberg Activation Manager (SAM), and then activated again - and sorted it.

So try that first, as it only takes a minute.


Good to know. Thank you!

Hi again,

I have around 10 vst sound files that are not working without Dongle and I have been in contact with Steinberg support and received the following information:

First of all there are still vsts that are not yet working without Dongle and they will be transformed during 2023.
Here you can find a list (sorry it is in German) with all vst that are working without Dongle and all vst that are not on the list still require a Dongle (eg Alto Glockenspiel):

(I am using WIN but should be the same for MAC)

1 Like

Hi all, without going into individual solutions for the questions in this topic. As @superwotan already found out, this transition is work in progress. Apologies for the confusion.
All HALion Sonic Collection and Absolute 6 content should work with the new licensing. If you run into any trouble that you can’t sort out yourselves (reinstall, deactivate/reactivate etc.), please search the knowledge base or contact support.
Thanks for your understanding and apologies again for any inconvenience, as we constantly try to make the installation smoother.