Some issues working with MIDI tracks

Hi Guys,

I played around to work with MIDI files as supporting backing tracks per song.

Here are some difficulties :

(1) Stuck notes when “STOP” on transport

I’m using the “Roland Sound Canvas” VST plugin (latest version out of Roland cloud).
Each track is using an own instance of the Roland Sound Canvas plugin (hope this is correct, I din’t find a way to use ONE instance for multiple tracks using different MIDI channels).

I start the song - ok, working.
I STOP the song and EVERY open MiDI note stucks/hangs. !!!

Sending PANIC/AllNotesOff from my masterkeyboard : no effect, the sounds still are there.
Pressing den Panic Button in VST live : the sounds disappear for one second but come back
Changing to another song in VST Live : sound disappears, but comes back when I return to the original (note hanging) song.

Only chance to get rid of the stuck sound : Restart VST Live.
This would be a desaster on stage and MUST NOT HAPPEN.

Minimum solution would be that an “All Notes Off” incoming from a MIDI in would be transferred to all active instruments (or could be triggered by any event in Actions and Shortcuts)

(2) multi file select for tracks import
It would be helpful when the file import dialog for MIDI files would allow to select multiple files (and the dialog “would you like to add a lyrics track” would only appear one time or could be disabled).

best solution would be to drag&drop from the DAW but this sometimes in tracks that are out of time.

Thanks for help and information.


Hi @gerhard.kiessling,

hm. I’ve tried to reproduce it. No luck. What have I done

  1. Start VL
  2. Select TRACKS
  3. Add MIDI Track and create a Clip from 2.1 to 3.1
  4. Open MIDI Edit and draw a MIDI Event for C3 from 2.1 to 3.1
  5. Insert HSSE to it and load Preset “All the Lovers”
  6. Locate Position 1.1, start Playback and stop Transport at 2.3.1

->No Problem. No handing note.

Can you confirm that one is working for you, too? What happens when insert “Roland Sound Canvas” to it? Is that the problem? Or your project at all? Or the multi instances?

Are you running the latest Pre-Release 1.1.51? You can find more details here.

good idea!

We’ll check that one, too.

… really? Always? DO you have a pattern? 1.1.55 has this problem, too?

Thank you,


I’m working with

The beaviour can be reproduced with Roland Sound Canvas-
I’ve also tried with Halion Sonic included in VST Live : NO PROBLEM here .

Steps (using Roland):
Import the two mid files in a songs tracks.
Every one is contain one note from 2.1 to 4.1
File 1 is sending on channel 1, file 2 on channel 2.
Assing instrument Roland Sound Canvas (1.16 Build 1160) to each.
As written originally these are two instances, correct ?
Assign any sound to Sound Canvas in Track1 listening on channel 1
Assign any sound to Sound Canvas in Track2 listening on channel 2
Play and stop at 3.1 => the second track will hang

As said : HSSE is working fine with it (that gives me an option to continue my work)

But :
Doing the same in my DAW (Cakewalk by Bandlab, also forcing two instances there), the Roland works as expected, no stuck.

Gerhard (469 Bytes)

sorry, I forgot the mid files.

and : I’ve upgraded to : same behaviour

I have tested this with Sound Canvas VA and the latest beta version (which you probably don’t have but will most likely be released very soon), and cannot reproduce it. The Sound Canvas VA plugin version is 1.1.6.
VST Live sends a standard MIDI “All Notes Off” command when stopped. It’s funny because the original Sound Canvas was one of the few at that time to implement this correctly :slight_smile:
So make sure to have their latest version.

ok, thanks.


just had a test with VST Live
The behaviour ist still faulty.

I had a close look to the MIDI traffic replacing the VST instrument through a MIDI monitor plugin.

Pressing START is sending each a MIDI note on :
Channel 1 on track 1
Channel 2 on track 2

Pressing STOP is sending note off
Channel 1 on track 1
Channel 1 (YES:ONE) on track 2 : this is causing the stuck note.

and is sending an all note off
Channel 1 on track 1
Channel 1 (ONE) on track 2

Seems the Roland VST (1.16 (S) Build 1160) does not recognize all notes off.
That doesn’t bother on channel 1 (there the note off did the trick), but keeps the note open on channel 2.

And now ?
Thanks for further help, especially how you got the example working in your environment (did you really) ?


Will check right away!

Double checked this and it’s not true here.
Each track (and also Layer) records note on commands and on stop, sends a note off for all of those commands that have not been deleted due to a note off meanwhile. The note off is sent with the channel of the track.
Followed the code up to where it sends to the plugin, it’s all correct.
Then shortcut midi cable from URC in to out and send there, then received via VST Live Midi Monitor. It’s all correct; 0x90 and 0x91 note on (channel 1 and 2) and according 0x80 and 0x81 note off for channel 1 and 2 resp. plus all notes off.
I have no idea how you get to your result. Do you have thje possibility to make such a MIDI cable shortcut test?


I’ve done exactly this, sent the tracks output to a physical MIDI Out (Roland Quad Capture) and connected this to its MIDI in, so I could track it with the MIDI Monitor of VST Live.

See attached. It’s the same result like yesterday.

Unfortunately the VST Live MIDI monitor does not show the channels (I complain about that since VST Live started), so from this output I cannot verify that the note off on track 2 is sent to channel 1 (but I could verify that yesterday)

So : “imho” the problem is VST Live based.

What I did as a workariound : I changed the “Channel” of the tracks to exactly the same channel that is addressed in the files note on.
That worked. The note off in track 2 now is sent on channel 2 (and is closing the note).

But that only works in my case, as my MIDI file are really separated “per channel”.
If I would have a multi-channel MIDI file that would be no option of course.

Let me say :
It’s frustrating. Since months in VST Life I spent 80% of the time with problems and cumbersome behavior instead of music.
Some day also tech interested guys lose the appetite.

It’s in the status, 0x90 is Note On channel “0” (say: 1), 0x91 is Note on on channel “1” (say: 2) etc. It’s hexadecimal, so it counts 9, a, b, c, d, e, f for channels “9 to 15” (say: 10 to 16), thus, 0x9f denotes Note On on channel 16.

There you are…now there is the problem, we will fix it with the next version. As I said before, the note off command for pending notes is sent with the MIDI channel as set in the track, which is “0” (channel 1) when set to “Any”. Thanks for pointing it out!

When searching this question online I find a string of cubase forum posts with a similar request dating back several years . Importing multiple midi files seems to be the one feature that for some reason has not been added years later. Not even in cubase 12 pro.

You can drag multiple files to the TRACKs view.